CVE-2024-3958 Improper Control of Generation of Code ('Code Injection') in GitLab

Medium 5.3 Published Updated

Attackers can trick users into cloning malicious code by exploiting discrepancies between GitLab's web display and the git CLI.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-3958?

CVE-2024-3958 is a medium-severity code injection vulnerability in Gitlab Gitlab, published on 8 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions before 17.0.6, 17.1 prior to 17.1.4, and 17.2 prior to 17.2.2. An issue was found that allows someone to abuse a discrepancy between the Web application display and the git command line interface to social engineer victims into cloning non-trusted code.

Weakness: CWE-94

Which versions are affected by CVE-2024-3958?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions17.0.6, 17.1.4, 17.2.2

Products include Gitlab Gitlab.

How do I fix CVE-2024-3958?

Upgrade gitlab to a fixed version for your release line: 17.0.6, 17.1.4 or 17.2.2.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2024-3958 being exploited?

There is no known exploitation of CVE-2024-3958 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-3958, GHSA-f8rc-7cqg-v9mm, UBUNTU-CVE-2024-3958.

Is CVE-2024-3958 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free