{"answers":{"affected":"1 open source package ship an affected version, including gitlab. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-3958 in the wild and no public exploit code.","fix":"Upgrade gitlab to a fixed version for your release line: 17.0.6, 17.1.4 or 17.2.2.","what":"CVE-2024-3958 is a medium-severity code injection vulnerability in Gitlab Gitlab, published on 8 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-3958 and fix it if it is affected.\n\nWhat it is: CVE-2024-3958 is a medium-severity code injection vulnerability in Gitlab Gitlab, published on 8 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-3958 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- gitlab (Bitnami): affected all versions; fixed in 17.0.6, 17.1.4, 17.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-3958/ (Markdown: https://insights.sbomify.com/CVE-2024-3958/index.md)","id":"CVE-2024-3958","markdown":"https://insights.sbomify.com/CVE-2024-3958/index.md","name":"CVE-2024-3958","record":{"aliases":["BIT-gitlab-2024-3958","GHSA-f8rc-7cqg-v9mm","UBUNTU-CVE-2024-3958"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"GitLab","requires_auth":"none","summary":"Attackers can trick users into cloning malicious code by exploiting discrepancies between GitLab's web display and the git CLI.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitLab","cpe":[{"product":"gitlab","vendor":"gitlab"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"An issue has been discovered in GitLab CE/EE affecting all versions before 17.0.6, 17.1 prior to 17.1.4, and 17.2 prior to 17.2.2. An issue was found that allows someone  to abuse a discrepancy between the Web application display and the git command line interface to social engineer victims into cloning non-trusted code.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Control of Generation of Code ('Code Injection') in GitLab","id":"CVE-2024-3958","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"gitlab:gitlab","products":["gitlab:gitlab"],"type":"code_injection","year":"2024"},"n_packages":1,"n_references":2,"next":{"headline":"Improper Authorization in GitLab","id":"CVE-2024-3959"},"packages":[{"ecosystem":"Bitnami","fixed":["17.0.6","17.1.4","17.2.2"],"introduced":["0","17.1.0","17.2.0"],"last_affected":[],"package":"gitlab","purl":"pkg:bitnami/gitlab","source":"BIT-gitlab-2024-3958"}],"prev":{"headline":"Booster for WooCommerce \u003c= 7.1.8 - Unauthenticated Arbitrary Shortcode Execution","id":"CVE-2024-3957"},"products":["GitLab"],"published":"2024-08-08","related":[{"cvss_score":10,"headline":"GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound","id":"CVE-2026-97229","kev_date_added":"2026-10-29","published":"2026-10-13"},{"cvss_score":10,"headline":"GitLab Community Edition and Enterprise Edition Path Traversal","id":"CVE-2026-85706","kev_date_added":"2026-09-11","published":"2026-09-12"},{"cvss_score":10,"headline":"GitLab Community and Enterprise Editions Improper Access Control","id":"CVE-2023-7028","kev_date_added":"2024-05-01","published":"2024-01-12"},{"cvss_score":10,"headline":"GitLab Community and Enterprise Editions Remote Code Execution","id":"CVE-2021-22205","kev_date_added":"2021-11-03","published":"2021-04-23"},{"cvss_score":6.8,"headline":"GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)","id":"CVE-2021-39935","kev_date_added":"2026-02-03","published":"2021-12-13"},{"cvss_score":6.8,"headline":"GitLab Server-Side Request Forgery (SSRF)","id":"CVE-2021-22175","kev_date_added":"2026-02-18","published":"2021-06-11"},{"cvss_score":10,"headline":"Integer Overflow or Wraparound in GitLab","id":"CVE-2026-110264","kev_date_added":null,"published":"2026-10-22"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-09-17","vendors":["GitLab"]},"summary":"Attackers can trick users into cloning malicious code by exploiting discrepancies between GitLab's web display and the git CLI.","url":"https://insights.sbomify.com/CVE-2024-3958/"}