# CVE-2024-3958: Improper Control of Generation of Code ('Code Injection') in GitLab

> Attackers can trick users into cloning malicious code by exploiting discrepancies between GitLab's web display and the git CLI.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Aug 2024
- **Updated:** 17 Sep 2024
- **Also known as:** BIT-gitlab-2024-3958, GHSA-f8rc-7cqg-v9mm, UBUNTU-CVE-2024-3958

## What is CVE-2024-3958?

CVE-2024-3958 is a medium-severity code injection vulnerability in Gitlab Gitlab, published on 8 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue has been discovered in GitLab CE/EE affecting all versions before 17.0.6, 17.1 prior to 17.1.4, and 17.2 prior to 17.2.2. An issue was found that allows someone  to abuse a discrepancy between the Web application display and the git command line interface to social engineer victims into cloning non-trusted code.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-3958?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | All versions | 17.0.6, 17.1.4, 17.2.2 |

Products: Gitlab Gitlab.

## How do I fix CVE-2024-3958?

Upgrade gitlab to a fixed version for your release line: 17.0.6, 17.1.4 or 17.2.2.

## Is CVE-2024-3958 being exploited?

There is no known exploitation of CVE-2024-3958 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-3958 and fix it if it is affected.

What it is: CVE-2024-3958 is a medium-severity code injection vulnerability in Gitlab Gitlab, published on 8 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-3958 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected all versions; fixed in 17.0.6, 17.1.4, 17.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-3958/ (Markdown: https://insights.sbomify.com/CVE-2024-3958/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-3958
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-3958
- OSV: https://osv.dev/vulnerability/CVE-2024-3958

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-3958/
Summaries are generated and may contain mistakes; the official description above is the record.
