CVE-2024-3959 Improper Authorization in GitLab

Medium 6.5 Published Updated

Attackers can access private job artifacts in GitLab due to improper authorization checks, exposing sensitive data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-3959?

CVE-2024-3959 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 26 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue was discovered in GitLab CE/EE affecting all versions starting from 16.7 prior to 16.11.5, starting from 17.0 prior to 17.0.3, and starting from 17.1 prior to 17.1.1, which allows private job artifacts can be accessed by any user.

Weakness: CWE-285

Which versions are affected by CVE-2024-3959?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.7.016.11.5, 17.0.3, 17.1.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-3959?

Upgrade gitlab to a fixed version for your release line: 16.11.5, 17.0.3 or 17.1.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-3959 being exploited?

There is no known exploitation of CVE-2024-3959 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-3959, GHSA-mmw4-rfwh-wm5m, UBUNTU-CVE-2024-3959.

Is CVE-2024-3959 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free