# CVE-2024-39683: ZITADEL Vulnerable to Session Information Leakage

> Attackers can view other users' session information due to missing checks in ZITADEL, exposing sensitive session data.

- **Severity:** Medium 5.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-cvw9-c57h-3397, GO-2024-2968

## What is CVE-2024-39683?

CVE-2024-39683 is a medium-severity vulnerability in zitadel, published on 3 Jul 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

ZITADEL is an open-source identity infrastructure tool. ZITADEL provides users the ability to list all user sessions of the current user agent (browser). Starting in version 2.53.0 and prior to versions 2.53.8, 2.54.5, and 2.55.1, due to a missing check, user sessions without that information (e.g. when created though the session service) were incorrectly listed exposing potentially other user's sessions. Versions 2.55.1, 2.54.5, and 2.53.8 contain a fix for the issue. There is no workaround since a patch is already available.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-39683?

7 open source packages ship an affected version, including github.com/zitadel/zitadel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/zitadel/zitadel` | Go | All versions | None |
| `github.com/zitadel/zitadel` | Go | From 2.0.0 | 2.53.8 |
| `github.com/zitadel/zitadel` | Go | From 2.0.0 | 2.53.8 |
| `github.com/zitadel/zitadel` | Go | From 2.54.0 | 2.54.5 |
| `github.com/zitadel/zitadel` | Go | From 2.54.0 | 2.54.5 |
| `github.com/zitadel/zitadel` | Go | From 2.55.0 | 2.55.1 |
| `github.com/zitadel/zitadel` | Go | From 2.55.0 | 2.55.1 |

Products: Zitadel Zitadel.

## How do I fix CVE-2024-39683?

Upgrade github.com/zitadel/zitadel to a fixed version for your release line: 2.53.8, 2.54.5 or 2.55.1.

## Is CVE-2024-39683 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-39683 exists.

## Other vulnerabilities in zitadel

- [CVE-2026-29191](https://insights.sbomify.com/CVE-2026-29191/): ZITADEL: 1-Click Account Takeover via XSS in /saml-post Endpoint (critical 9.3)
- [CVE-2025-67494](https://insights.sbomify.com/CVE-2025-67494/): ZITADEL Vulnerable to Unauthenticated Full-Read SSRF via V2 Login (critical 9.3)
- [CVE-2025-27507](https://insights.sbomify.com/CVE-2025-27507/): IDOR Vulnerabilities in ZITADEL's Admin API that Primarily Impact LDAP Configurations (critical 9.0)
- [CVE-2025-64103](https://insights.sbomify.com/CVE-2025-64103/): Zitadel Bypass Second Authentication Factor (high 8.7)
- [CVE-2025-31123](https://insights.sbomify.com/CVE-2025-31123/): Zitadel Expired JWT Keys Usable for Authorization Grants (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39683 and fix it if it is affected.

What it is: CVE-2024-39683 is a medium-severity vulnerability in zitadel, published on 3 Jul 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-39683 exists.

Affected packages and fixed versions:
- github.com/zitadel/zitadel (Go): affected all versions; no fix listed
- github.com/zitadel/zitadel (Go): affected from 2.0.0; fixed in 2.53.8
- github.com/zitadel/zitadel (Go): affected from 2.0.0; fixed in 2.53.8
- github.com/zitadel/zitadel (Go): affected from 2.54.0; fixed in 2.54.5
- github.com/zitadel/zitadel (Go): affected from 2.54.0; fixed in 2.54.5
- github.com/zitadel/zitadel (Go): affected from 2.55.0; fixed in 2.55.1
- github.com/zitadel/zitadel (Go): affected from 2.55.0; fixed in 2.55.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39683/ (Markdown: https://insights.sbomify.com/CVE-2024-39683/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39683
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39683
- OSV: https://osv.dev/vulnerability/CVE-2024-39683

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39683/
Summaries are generated and may contain mistakes; the official description above is the record.
