{"answers":{"affected":"3 open source packages ship an affected version, including certifi. It affects 4 products.","exploited":"There is no known exploitation of CVE-2024-39689 in the wild and no public exploit code.","fix":"Upgrade certifi to 2024.7.4 or later.","what":"CVE-2024-39689 is a high-severity vulnerability in Netapp Ontap Select Deploy Administration Utility, published on 5 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-39689 and fix it if it is affected.\n\nWhat it is: CVE-2024-39689 is a high-severity vulnerability in Netapp Ontap Select Deploy Administration Utility, published on 5 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-39689 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- certifi (PyPI): affected from 2021.5.30; fixed in 2024.7.4\n- certifi (PyPI): affected from 2021.5.30; fixed in 2024.7.4\n- certifi (PyPI): affected from 2021.5.30; fixed in 2024.7.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-39689/ (Markdown: https://insights.sbomify.com/CVE-2024-39689/index.md)","id":"CVE-2024-39689","markdown":"https://insights.sbomify.com/CVE-2024-39689/index.md","name":"CVE-2024-39689","record":{"aliases":["CLSA-2026-1785815308","CLSA-2026-1785934478","DEBIAN-CVE-2024-39689","ECHO-2c05-8db5-680f","GHSA-248v-346w-9cwc","MINI-355w-fjgc-xxwj","MINI-mxjf-f95p-v8v9","OESA-2026-2145","PYSEC-2024-230","ROOT-APP-PYPI-CVE-2024-39689","openSUSE-SU-2024:14118-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python root certificate bundle","requires_auth":"none","summary":"Outdated root certificates in the certifi library allow potential trust of compromised authorities, requiring an upgrade to remove them.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"certifi","vendor":"certifi"},{"product":"management_services_for_element_software_and_netapp_hci","vendor":"netapp"},{"product":"ontap_select_deploy_administration_utility","vendor":"netapp"},{"product":"ontap_tools","vendor":"netapp"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-345","name":"Insufficient Verification of Data Authenticity"}],"description":"Certifi is a curated collection of Root Certificates for validating the trustworthiness of SSL certificates while verifying the identity of TLS hosts. Certifi starting in 2021.5.30 and prior to 2024.7.4 recognized root certificates from `GLOBALTRUST`. Certifi 2024.7.04 removes root certificates from `GLOBALTRUST` from the root store. These are in the process of being removed from Mozilla's trust store. `GLOBALTRUST`'s root certificates are being removed pursuant to an investigation which identified \"long-running and unresolved compliance issues.\"","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":"2024-03-20","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-03-20T14:16:38Z","kind":"github_poc","ref":"https://github.com/roy-aladin/InfraTest","stars":0,"title":"DO NOT FORK, DEPLOY, OR USE FOR ANYTHING BUT LEARNING. These requirements are vulnerable to CVE-2024-39689"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Certifi removes GLOBALTRUST root certificate","id":"CVE-2024-39689","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"netapp:ontap_select_deploy_administration_utility","products":["netapp:ontap_select_deploy_administration_utility"],"type":"supply_chain","year":"2024"},"n_packages":4,"n_references":3,"next":{"headline":"Capsule tenant owner with \"patch namespace\" permission can hijack system namespaces","id":"CVE-2024-39690"},"packages":[{"ecosystem":"PyPI","fixed":["2024.7.4"],"introduced":["2021.5.30"],"last_affected":[],"package":"certifi","purl":null,"source":"GHSA-248v-346w-9cwc"},{"ecosystem":"PyPI","fixed":["2024.7.4"],"introduced":["2021.5.30"],"last_affected":[],"package":"certifi","purl":"pkg:pypi/certifi","source":"GHSA-248v-346w-9cwc"},{"ecosystem":"PyPI","fixed":["2024.7.4"],"introduced":["2021.5.30"],"last_affected":[],"package":"certifi","purl":"pkg:pypi/certifi","source":"PYSEC-2024-230"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2024.7.4-1.1"],"introduced":["0"],"last_affected":[],"package":"python-certifi","purl":"pkg:rpm/opensuse/python-certifi\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:14118-1"}],"prev":{"headline":"fishaudio/Bert-VITS2 Limited File Write in webui_preprocess.py generate_config function","id":"CVE-2024-39688"},"products":["python-certifi"],"published":"2024-07-05","related":[{"cvss_score":7.5,"headline":"Certifi's removal of e-Tugra root certificate","id":"CVE-2023-37920","kev_date_added":null,"published":"2023-07-25"},{"cvss_score":6.8,"headline":"Removal of TrustCor root certificate","id":"CVE-2022-23491","kev_date_added":null,"published":"2022-12-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-14","vendors":["certifi"]},"summary":"Outdated root certificates in the certifi library allow potential trust of compromised authorities, requiring an upgrade to remove them.","url":"https://insights.sbomify.com/CVE-2024-39689/"}