# CVE-2024-39689: Certifi removes GLOBALTRUST root certificate

> Outdated root certificates in the certifi library allow potential trust of compromised authorities, requiring an upgrade to remove them.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jul 2024
- **Updated:** 14 Feb 2025
- **Also known as:** CLSA-2026-1785815308, CLSA-2026-1785934478, DEBIAN-CVE-2024-39689, ECHO-2c05-8db5-680f, GHSA-248v-346w-9cwc, MINI-355w-fjgc-xxwj, MINI-mxjf-f95p-v8v9, OESA-2026-2145, PYSEC-2024-230, ROOT-APP-PYPI-CVE-2024-39689, openSUSE-SU-2024:14118-1

## What is CVE-2024-39689?

CVE-2024-39689 is a high-severity vulnerability in Netapp Ontap Select Deploy Administration Utility, published on 5 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Certifi is a curated collection of Root Certificates for validating the trustworthiness of SSL certificates while verifying the identity of TLS hosts. Certifi starting in 2021.5.30 and prior to 2024.7.4 recognized root certificates from `GLOBALTRUST`. Certifi 2024.7.04 removes root certificates from `GLOBALTRUST` from the root store. These are in the process of being removed from Mozilla's trust store. `GLOBALTRUST`'s root certificates are being removed pursuant to an investigation which identified "long-running and unresolved compliance issues."

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2024-39689?

3 open source packages ship an affected version, including certifi. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `certifi` | PyPI | From 2021.5.30 | 2024.7.4 |
| `certifi` | PyPI | From 2021.5.30 | 2024.7.4 |
| `certifi` | PyPI | From 2021.5.30 | 2024.7.4 |
| `python-certifi` | openSUSE:Tumbleweed | All versions | 2024.7.4-1.1 |

Products: Certifi Certifi, Netapp Management Services for Element Software and Netapp Hci, Netapp Ontap Select Deploy Administration Utility, Netapp Ontap Tools.

## How do I fix CVE-2024-39689?

Upgrade certifi to 2024.7.4 or later.

## Is CVE-2024-39689 being exploited?

There is no known exploitation of CVE-2024-39689 in the wild and no public exploit code.

Public exploit code:

- DO NOT FORK, DEPLOY, OR USE FOR ANYTHING BUT LEARNING. These requirements are vulnerable to CVE-2024-39689 (github_poc): https://github.com/roy-aladin/InfraTest

## Other vulnerabilities in Netapp Ontap Select Deploy Administration Utility

- [CVE-2023-37920](https://insights.sbomify.com/CVE-2023-37920/): Certifi's removal of e-Tugra root certificate (high 7.5)
- [CVE-2022-23491](https://insights.sbomify.com/CVE-2022-23491/): Removal of TrustCor root certificate (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39689 and fix it if it is affected.

What it is: CVE-2024-39689 is a high-severity vulnerability in Netapp Ontap Select Deploy Administration Utility, published on 5 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-39689 in the wild and no public exploit code.

Affected packages and fixed versions:
- certifi (PyPI): affected from 2021.5.30; fixed in 2024.7.4
- certifi (PyPI): affected from 2021.5.30; fixed in 2024.7.4
- certifi (PyPI): affected from 2021.5.30; fixed in 2024.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39689/ (Markdown: https://insights.sbomify.com/CVE-2024-39689/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39689
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39689
- OSV: https://osv.dev/vulnerability/CVE-2024-39689

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39689/
Summaries are generated and may contain mistakes; the official description above is the record.
