CVE-2024-39693 Next.js Denial of Service (DoS) condition

High 7.5 Published Updated

Attackers can trigger a server crash in Next.js, causing a denial of service and affecting availability.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-39693?

CVE-2024-39693 is a high-severity denial of service vulnerability in Vercel Next.js, published on 10 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Next.js is a React framework. A Denial of Service (DoS) condition was identified in Next.js. Exploitation of the bug can trigger a crash, affecting the availability of the server. his vulnerability was resolved in Next.js 13.5 and later.

Weakness: CWE-400

Which versions are affected by CVE-2024-39693?

2 open source packages ship an affected version, including next. It affects 1 product.

PackageAffectedFixed in
next npmFrom 13.3.113.5.0
next npmFrom 13.3.113.5.0

Products include Vercel Next.js.

How do I fix CVE-2024-39693?

Upgrade next to 13.5.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-39693 being exploited?

There is no known exploitation of CVE-2024-39693 in the wild and no public exploit code.

All Vercel Next.js vulnerabilities

Sources

Also known as GHSA-fq54-2j52-jc42, ROOT-APP-NPM-CVE-2024-39693.

Is CVE-2024-39693 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free