{"answers":{"affected":"2 open source packages ship an affected version, including jupyterlab. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-39700 exists.","fix":"Upgrade jupyterlab to 4.3.0 or later.","what":"CVE-2024-39700 is a critical code injection vulnerability in jupyterlab extension-template, published on 16 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-39700 and fix it if it is affected.\n\nWhat it is: CVE-2024-39700 is a critical code injection vulnerability in jupyterlab extension-template, published on 16 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-39700 exists.\n\nAffected packages and fixed versions:\n- jupyterlab (Bitnami): affected all versions; fixed in 4.3.0\n- jupyterlab (PyPI): affected all versions; fixed in 4.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-39700/ (Markdown: https://insights.sbomify.com/CVE-2024-39700/index.md)","id":"CVE-2024-39700","markdown":"https://insights.sbomify.com/CVE-2024-39700/index.md","name":"CVE-2024-39700","record":{"aliases":["BIT-jupyterlab-2024-39700","GHSA-45gq-v5wm-82wg","PYSEC-2024-322"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"JupyterLab extension template","requires_auth":"low_privilege","summary":"Remote code execution in JupyterLab extension template's GitHub Action allows attackers to execute arbitrary code via malicious pull requests.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"jupyterlab","vendor":"jupyter"}],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"JupyterLab extension template is a  `copier` template for JupyterLab extensions. Repositories created using this template with `test` option include `update-integration-tests.yml` workflow which has an RCE vulnerability. Extension authors hosting their code on GitHub are urged to upgrade the template to the latest version. Users who made changes to `update-integration-tests.yml`, accept overwriting of this file and re-apply your changes later. Users may wish to temporarily disable GitHub Actions while working on the upgrade. We recommend rebasing all open pull requests from untrusted users as actions may run using the version from the `main` branch at the time when the pull request was created. Users who are upgrading from template version prior to 4.3.0 may wish to leave out proposed changes to the release workflow for now as it requires additional configuration.","ecosystems":["Bitnami","PyPI"],"exploits":{"exploitdb":0,"first_seen":"2024-07-29","github_poc":2,"max_poc_stars":1,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-07-29T08:33:12Z","kind":"github_poc","ref":"https://github.com/LOURC0D3/CVE-2024-39700-PoC","stars":1,"title":"CVE-2024-39700 Proof of Concept"},{"date":"2026-09-01T11:22:57Z","kind":"github_poc","ref":"https://github.com/pvharmo2/gha-lab-0ba60e6456","stars":0,"title":"Authorized security-research lab reproducing CVE-2024-39700 / GHSA-45gq-v5wm-82wg (JupyterLab extension-template update-integration-tests pwn request)"}],"tier":"weaponised"},"has_fix":true,"headline":"Remote Code Execution (RCE) vulnerability in jupyterlab extension template `update-integration-tests` GitHub Action","id":"CVE-2024-39700","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Directus Incorrectly handles _in` filter","id":"CVE-2024-39701"},"packages":[{"ecosystem":"Bitnami","fixed":["4.3.0"],"introduced":["0"],"last_affected":[],"package":"jupyterlab","purl":"pkg:bitnami/jupyterlab","source":"BIT-jupyterlab-2024-39700"},{"ecosystem":"PyPI","fixed":["4.3.0"],"introduced":["0"],"last_affected":[],"package":"jupyterlab","purl":"pkg:pypi/jupyterlab","source":"PYSEC-2024-322"}],"prev":{"headline":"Directus has a Blind SSRF On File Import","id":"CVE-2024-39699"},"products":["extension-template"],"published":"2024-07-16","related":[{"cvss_score":8.8,"headline":"JupyterLab has an Extension Manager API/GUI Policy Discrepancy, allowing 3rd party (malicious) extensions install via POST request","id":"CVE-2026-42266","kev_date_added":null,"published":"2026-05-13"},{"cvss_score":8.6,"headline":"jupyterlab: Command linker attributes in HTML enable one-click command execution from untrusted content","id":"CVE-2026-42557","kev_date_added":null,"published":"2026-05-13"},{"cvss_score":7.6,"headline":"HTML injection in Jupyter Notebook and JupyterLab leading to DOM Clobbering","id":"CVE-2024-43805","kev_date_added":null,"published":"2024-08-28"},{"cvss_score":7.4,"headline":"JupyterLab: XSS due to lack of sanitization of the action attribute of an html \u003cform\u003e","id":"CVE-2021-32797","kev_date_added":null,"published":"2021-08-09"},{"cvss_score":2.1,"headline":"JupyterLab LaTeX typesetter links did not enforce `noopener` attribute","id":"CVE-2025-59842","kev_date_added":null,"published":"2025-09-26"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-16","vendors":["jupyterlab"]},"summary":"Remote code execution in JupyterLab extension template's GitHub Action allows attackers to execute arbitrary code via malicious pull requests.","url":"https://insights.sbomify.com/CVE-2024-39700/"}