{"answers":{"affected":"3 open source packages ship an affected version, including nltk.","exploited":"There is no known exploitation of CVE-2024-39705 in the wild and no public exploit code.","fix":"Upgrade nltk to 3.9 or later.","what":"CVE-2024-39705 is a critical unsafe deserialization vulnerability in n/a, published on 27 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-39705 and fix it if it is affected.\n\nWhat it is: CVE-2024-39705 is a critical unsafe deserialization vulnerability in n/a, published on 27 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-39705 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nltk (PyPI): affected all versions; fixed in 3.9\n- nltk (PyPI): affected all versions; fixed in 3.9\n- nltk (PyPI): affected all versions; fixed in 3.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-39705/ (Markdown: https://insights.sbomify.com/CVE-2024-39705/index.md)","id":"CVE-2024-39705","markdown":"https://insights.sbomify.com/CVE-2024-39705/index.md","name":"CVE-2024-39705","record":{"aliases":["DEBIAN-CVE-2024-39705","GHSA-cgvx-9447-vcch","PYSEC-2024-167","UBUNTU-CVE-2024-39705","openSUSE-SU-2024:0221-1","openSUSE-SU-2024:0222-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Python NLP library","requires_auth":"none","summary":"Remote code execution occurs in NLTK when downloading untrusted pickled data packages, requiring the use of integrated download functionality.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"NLTK through 3.8.1 allows remote code execution if untrusted packages have pickled Python code, and the integrated data package download functionality is used. This affects, for example, averaged_perceptron_tagger and punkt.","ecosystems":["PyPI","SUSE:Package Hub 15 SP5","SUSE:Package Hub 15 SP6","openSUSE:Leap 15.5","openSUSE:Leap 15.6"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ntlk unsafe deserialization vulnerability","id":"CVE-2024-39705","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2024"},"n_packages":7,"n_references":3,"next":{"headline":"Missing authorization in n/a","id":"CVE-2024-39707"},"packages":[{"ecosystem":"PyPI","fixed":["3.9"],"introduced":["0"],"last_affected":[],"package":"nltk","purl":null,"source":"GHSA-cgvx-9447-vcch"},{"ecosystem":"PyPI","fixed":["3.9"],"introduced":["0"],"last_affected":[],"package":"nltk","purl":"pkg:pypi/nltk","source":"GHSA-cgvx-9447-vcch"},{"ecosystem":"PyPI","fixed":["3.9"],"introduced":["0"],"last_affected":[],"package":"nltk","purl":"pkg:pypi/nltk","source":"PYSEC-2024-167"},{"ecosystem":"SUSE:Package Hub 15 SP5","fixed":["3.7-bp155.3.3.1"],"introduced":["0"],"last_affected":[],"package":"python-nltk","purl":"pkg:rpm/suse/python-nltk\u0026distro=SUSE%20Package%20Hub%2015%20SP5","source":"openSUSE-SU-2024:0222-1"},{"ecosystem":"SUSE:Package Hub 15 SP6","fixed":["3.7-bp156.4.3.1"],"introduced":["0"],"last_affected":[],"package":"python-nltk","purl":"pkg:rpm/suse/python-nltk\u0026distro=SUSE%20Package%20Hub%2015%20SP6","source":"openSUSE-SU-2024:0221-1"},{"ecosystem":"openSUSE:Leap 15.5","fixed":["3.7-bp155.3.3.1"],"introduced":["0"],"last_affected":[],"package":"python-nltk","purl":"pkg:rpm/opensuse/python-nltk\u0026distro=openSUSE%20Leap%2015.5","source":"openSUSE-SU-2024:0222-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["3.7-bp156.4.3.1"],"introduced":["0"],"last_affected":[],"package":"python-nltk","purl":"pkg:rpm/opensuse/python-nltk\u0026distro=openSUSE%20Leap%2015.6","source":"openSUSE-SU-2024:0221-1"}],"prev":{"headline":"Code injection in n/a","id":"CVE-2024-39704"},"products":["n/a"],"published":"2024-06-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-09-15","vendors":["n/a"]},"summary":"Remote code execution occurs in NLTK when downloading untrusted pickled data packages, requiring the use of integrated download functionality.","url":"https://insights.sbomify.com/CVE-2024-39705/"}