# CVE-2024-39713: Rocket.Chat Server-Side Request Forgery (SSRF) vulnerability

> An attacker can exploit a Server-Side Request Forgery vulnerability in Rocket.Chat's Twilio webhook endpoint to access internal resources.

- **Severity:** High 8.6 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Aug 2024
- **Updated:** 6 Sep 2024
- **Also known as:** GHSA-ffxg-5f8m-h72j

## What is CVE-2024-39713?

CVE-2024-39713 is a high-severity server-side request forgery vulnerability in Rocket.chat Rocket.chat, published on 5 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Server-Side Request Forgery (SSRF) affects Rocket.Chat's Twilio webhook endpoint before version 6.10.1.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2024-39713?

2 open source packages ship an affected version, including rocket.chat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rocket.chat` | npm | All versions | 6.10.1 |
| `rocket.chat` | npm | All versions | 6.10.1 |

Products: Rocket.chat Rocket.chat.

## How do I fix CVE-2024-39713?

Upgrade rocket.chat to 6.10.1 or later.

## Is CVE-2024-39713 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-39713 exists.

Public exploit code:

- https://github.com/typical-pashochek/CVE-2024-39713 (github_poc): https://github.com/typical-pashochek/CVE-2024-39713
- CVE-2024-39713 (Rocket.Chat Blind SSRF vulnerability) (github_poc): https://github.com/blackcodersec/exploit-cve
- Rocket.Chat - Server-Side Request Forgery (SSRF) (nuclei): http/cves/2024/CVE-2024-39713.yaml

## Other vulnerabilities in Rocket.chat Rocket.chat

- [CVE-2026-58066](https://insights.sbomify.com/CVE-2026-58066/): Auth bypass in Rocket.Chat (critical 9.8)
- [CVE-2026-29198](https://insights.sbomify.com/CVE-2026-29198/): SQL injection in Rocket.Chat (critical 9.8)
- [CVE-2023-28316](https://insights.sbomify.com/CVE-2023-28316/): Security feature bypass in Rocket.Chat (critical 9.8)
- [CVE-2022-44567](https://insights.sbomify.com/CVE-2022-44567/): Command injection in Rocket.chat - Electron Desktop (critical 9.8)
- [CVE-2021-22910](https://insights.sbomify.com/CVE-2021-22910/): Code injection in Rocket.Chat server (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39713 and fix it if it is affected.

What it is: CVE-2024-39713 is a high-severity server-side request forgery vulnerability in Rocket.chat Rocket.chat, published on 5 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-39713 exists.

Affected packages and fixed versions:
- rocket.chat (npm): affected all versions; fixed in 6.10.1
- rocket.chat (npm): affected all versions; fixed in 6.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39713/ (Markdown: https://insights.sbomify.com/CVE-2024-39713/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39713
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39713
- OSV: https://osv.dev/vulnerability/CVE-2024-39713

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39713/
Summaries are generated and may contain mistakes; the official description above is the record.
