# CVE-2024-39720: Ollama Out-of-bounds Read

> An attacker can crash the Ollama server by uploading a malformed GGUF file and referencing it in a custom Modelfile, causing a segmentation fault.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Oct 2024
- **Updated:** 1 Nov 2024
- **Also known as:** GHSA-95j2-w8x7-hm88, GO-2024-3245

## What is CVE-2024-39720?

CVE-2024-39720 is a high-severity denial of service vulnerability in n/a, published on 31 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Ollama before 0.1.46. An attacker can use two HTTP requests to upload a malformed GGUF file containing just 4 bytes starting with the GGUF custom magic header. By leveraging a custom Modelfile that includes a FROM statement pointing to the attacker-controlled blob file, the attacker can crash the application through the CreateModel route, leading to a segmentation fault (signal SIGSEGV: segmentation violation).

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2024-39720?

3 open source packages ship an affected version, including github.com/ollama/ollama. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/ollama/ollama` | Go | All versions | 0.1.46 |
| `github.com/ollama/ollama` | Go | All versions | 0.1.46 |
| `github.com/ollama/ollama` | Go | All versions | 0.1.46 |

Products: Ollama Ollama.

## How do I fix CVE-2024-39720?

Upgrade github.com/ollama/ollama to 0.1.46 or later.

## Is CVE-2024-39720 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-39720 exists.

## Other vulnerabilities in n/a

- [CVE-2025-63389](https://insights.sbomify.com/CVE-2025-63389/): Ollama Platform has missing authentication enabling attackers to perform model management operations (critical 9.8)
- [CVE-2024-45436](https://insights.sbomify.com/CVE-2024-45436/): Ollama can extract members of a ZIP archive outside of the parent directory (critical 9.1)
- [CVE-2026-7482](https://insights.sbomify.com/CVE-2026-7482/): Ollama heap out-of-bounds read in GGUF tensor parsing leaks server process memory to unauthenticated remote attackers (high 8.8)
- [CVE-2024-37032](https://insights.sbomify.com/CVE-2024-37032/): Ollama does not validate the format of the digest (sha256 with 64 hex digits) (high 8.8)
- [CVE-2025-15514](https://insights.sbomify.com/CVE-2025-15514/): Ollama Multi-Modal Model Image Processing NULL Pointer Dereference (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39720 and fix it if it is affected.

What it is: CVE-2024-39720 is a high-severity denial of service vulnerability in n/a, published on 31 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-39720 exists.

Affected packages and fixed versions:
- github.com/ollama/ollama (Go): affected all versions; fixed in 0.1.46
- github.com/ollama/ollama (Go): affected all versions; fixed in 0.1.46
- github.com/ollama/ollama (Go): affected all versions; fixed in 0.1.46

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39720/ (Markdown: https://insights.sbomify.com/CVE-2024-39720/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39720
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39720
- OSV: https://osv.dev/vulnerability/CVE-2024-39720

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39720/
Summaries are generated and may contain mistakes; the official description above is the record.
