CVE-2024-39777 Malicious remote can invite itself to an arbitrary local channel
A malicious remote user can force-share local channels without admin consent when shared channels are enabled, exposing local data.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-39777?
CVE-2024-39777 is a high-severity missing authorization vulnerability in Mattermost Mattermost, published on 1 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Mattermost versions 9.9.x <= 9.9.0, 9.5.x <= 9.5.6, 9.7.x <= 9.7.5 and 9.8.x <= 9.8.1 fail to disallow unsolicited invites to expose access to local channels, when shared channels are enabled, which allows a malicious remote to send an invite with the ID of an existing local channel, and that local channel will then become shared without the consent of the local admin.
Weakness: CWE-284
Which versions are affected by CVE-2024-39777?
12 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | From 9.5.0 | 9.5.7 |
github.com/mattermost/mattermost/server/v8 Go | From 9.5.0 | 9.5.7 |
github.com/mattermost/mattermost/server/v8 Go | From 9.7.0 | 9.7.6 |
github.com/mattermost/mattermost/server/v8 Go | From 9.7.0 | 9.7.6 |
github.com/mattermost/mattermost/server/v8 Go | From 9.8.0 | 9.8.1 |
6 more packages
github.com/mattermost/mattermost/server/v8 Go | From 9.8.0 | 9.8.1 |
github.com/mattermost/mattermost/server/v8 Go | From 9.9.0 | 9.9.1 |
github.com/mattermost/mattermost/server/v8 Go | From 9.9.0 | 9.9.1 |
github.com/mattermost/mattermost-server Go | From 9.5.0+incompatible | 9.5.7+incompatible, 9.7.6+incompatible, 9.8.1+incompatible, 9.9.1+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost.
How do I fix CVE-2024-39777?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 9.5.7, 9.7.6, 9.8.1 or 9.9.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-39777 being exploited?
There is no known exploitation of CVE-2024-39777 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost
- CVE-2019-20851 Path traversal in n/a
- CVE-2024-39274 Malicious remote can add users to arbitrary teams and channels
- CVE-2024-39830 Timing attack during remote cluster token comparison when shared channels are enabled
- CVE-2023-3615 Lack of server certificate validation in websockets connection
- CVE-2020-13891 Information disclosure in n/a
Sources
Also known as GHSA-q22q-2rrf-m27p, GO-2024-3092.