CVE-2024-39832 Permanently local data deletion by malicious remote

Medium 6.8 Published Updated

A malicious remote user can permanently delete local data via unsafe error handling when share channels are enabled.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-39832?

CVE-2024-39832 is a medium-severity vulnerability in Mattermost Mattermost, published on 1 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Mattermost versions 9.9.x <= 9.9.0, 9.5.x <= 9.5.6, 9.7.x <= 9.7.5, 9.8.x <= 9.8.1 fail to properly safeguard an error handling which allows a malicious remote to permanently delete local data by abusing dangerous error handling, when share channels were enabled.

Weakness: CWE-754

Which versions are affected by CVE-2024-39832?

12 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost/server/v8 GoAll versionsNone
github.com/mattermost/mattermost/server/v8 GoFrom 9.5.09.5.7
github.com/mattermost/mattermost/server/v8 GoFrom 9.5.09.5.7
github.com/mattermost/mattermost/server/v8 GoFrom 9.7.09.7.6
github.com/mattermost/mattermost/server/v8 GoFrom 9.7.09.7.6
github.com/mattermost/mattermost/server/v8 GoFrom 9.8.09.8.2
6 more packages
github.com/mattermost/mattermost/server/v8 GoFrom 9.8.09.8.2
github.com/mattermost/mattermost/server/v8 GoFrom 9.9.09.9.1
github.com/mattermost/mattermost/server/v8 GoFrom 9.9.09.9.1
github.com/mattermost/mattermost-server GoFrom 9.5.0+incompatible9.5.7+incompatible, 9.7.6+incompatible, 9.8.2+incompatible, 9.9.1+incompatible
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versionsNone

Products include Mattermost Mattermost.

How do I fix CVE-2024-39832?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 9.5.7, 9.7.6, 9.8.2 or 9.9.1.

Is CVE-2024-39832 being exploited?

There is no known exploitation of CVE-2024-39832 in the wild and no public exploit code.

All Mattermost Mattermost vulnerabilities

Sources

Also known as GHSA-762m-4cx6-6mf4, GO-2024-3020.

Is CVE-2024-39832 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free