CVE-2024-39837 Malicious remote can create arbitrary channels

Low 3.8 Published Updated

A malicious remote user can create arbitrary channels in Mattermost when shared channels are enabled, due to insufficient authorization checks.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-39837?

CVE-2024-39837 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 1 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Mattermost versions 9.9.x <= 9.9.0, 9.5.x <= 9.5.6 fail to properly restrict channel creation which allows a malicious remote to create arbitrary channels, when shared channels were enabled.

Weakness: CWE-284

Which versions are affected by CVE-2024-39837?

19 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, mattermost and github.com/mattermost/mattermost-server. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost/server/v8 GoAll versionsNone
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20240626164322-c758cecaf30c
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20240626164322-c758cecaf30c
github.com/mattermost/mattermost/server/v8 GoFrom 9.5.09.5.7
github.com/mattermost/mattermost/server/v8 GoFrom 9.5.09.5.7
github.com/mattermost/mattermost/server/v8 GoFrom 9.9.09.9.1
13 more packages
github.com/mattermost/mattermost/server/v8 GoFrom 9.9.09.9.1
mattermost BitnamiFrom 9.5.0 to 9.9.09.5.7
github.com/mattermost/mattermost-server GoFrom 9.5.09.5.7
github.com/mattermost/mattermost-server GoFrom 9.5.09.5.7
github.com/mattermost/mattermost-server GoFrom 9.5.0+incompatible9.5.7+incompatible, 9.9.1+incompatible
github.com/mattermost/mattermost-server GoFrom 9.9.09.9.1
github.com/mattermost/mattermost-server GoFrom 9.9.09.9.1
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v5 GoAll versions5.3.2-0.20240626164322-c758cecaf30c
github.com/mattermost/mattermost-server/v5 GoAll versions5.3.2-0.20240626164322-c758cecaf30c
github.com/mattermost/mattermost-server/v6 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versions6.0.0-20240626164322-c758cecaf30c
github.com/mattermost/mattermost-server/v6 GoAll versions6.0.0-20240626164322-c758cecaf30c

Products include Mattermost Mattermost Server.

How do I fix CVE-2024-39837?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20240626164322-c758cecaf30c, 9.5.7 or 9.9.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-39837 being exploited?

There is no known exploitation of CVE-2024-39837 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as BIT-mattermost-2024-39837, GHSA-vvpg-55p7-5h8w, GO-2024-3032.

Is CVE-2024-39837 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free