{"answers":{"affected":"4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-39863 in the wild and no public exploit code.","fix":"Upgrade apache-airflow to 2.9.3 or later.","what":"CVE-2024-39863 is a high-severity cross-site scripting vulnerability in Apache Airflow, published on 17 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-39863 and fix it if it is affected.\n\nWhat it is: CVE-2024-39863 is a high-severity cross-site scripting vulnerability in Apache Airflow, published on 17 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-39863 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-airflow (PyPI): affected all versions; fixed in 2.9.3\n- apache-airflow (PyPI): affected all versions; fixed in 2.9.3\n- apache-airflow (PyPI): affected all versions; fixed in 2.9.3\n- airflow (Bitnami): affected all versions; fixed in 2.9.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-39863/ (Markdown: https://insights.sbomify.com/CVE-2024-39863/index.md)","id":"CVE-2024-39863","markdown":"https://insights.sbomify.com/CVE-2024-39863/index.md","name":"CVE-2024-39863","record":{"aliases":["BIT-airflow-2024-39863","ECHO-7034-9751-0b4f","GHSA-j482-47xf-p25c","PYSEC-2024-189"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Airflow","requires_auth":"low_privilege","summary":"An authenticated attacker can inject malicious links during provider installation in Apache Airflow, potentially leading to cross-site scripting attacks.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"airflow","vendor":"apache"}],"cvss":{"score":8.1,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Apache Airflow versions before 2.9.3 have a vulnerability that allows an authenticated attacker to inject a malicious link when installing a provider. Users are recommended to upgrade to version 2.9.3, which fixes this issue.","ecosystems":["Bitnami","PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Airflow: Potential XSS Vulnerability","id":"CVE-2024-39863","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:airflow","products":["apache:airflow"],"type":"xss","year":"2024"},"n_packages":4,"n_references":2,"next":{"headline":"Apache CloudStack: Integration API service uses dynamic port when disabled","id":"CVE-2024-39864"},"packages":[{"ecosystem":"Bitnami","fixed":["2.9.3"],"introduced":["0"],"last_affected":[],"package":"airflow","purl":"pkg:bitnami/airflow","source":"BIT-airflow-2024-39863"},{"ecosystem":"PyPI","fixed":["2.9.3"],"introduced":["0"],"last_affected":[],"package":"apache-airflow","purl":null,"source":"GHSA-j482-47xf-p25c"},{"ecosystem":"PyPI","fixed":["2.9.3"],"introduced":["0"],"last_affected":[],"package":"apache-airflow","purl":"pkg:pypi/apache-airflow","source":"GHSA-j482-47xf-p25c"},{"ecosystem":"PyPI","fixed":["2.9.3"],"introduced":["0"],"last_affected":[],"package":"apache-airflow","purl":"pkg:pypi/apache-airflow","source":"PYSEC-2024-189"}],"prev":{"headline":"Code injection in n/a","id":"CVE-2024-39853"},"products":["Apache Airflow"],"published":"2024-07-17","related":[{"cvss_score":9.8,"headline":"Apache Airflow's Experimental API Authentication Bypass","id":"CVE-2020-13927","kev_date_added":"2022-01-18","published":"2020-11-10"},{"cvss_score":8.8,"headline":"Apache Airflow Command Injection","id":"CVE-2020-11978","kev_date_added":"2022-01-18","published":"2020-07-16"},{"cvss_score":9.8,"headline":"Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize()","id":"CVE-2026-33264","kev_date_added":null,"published":"2026-07-07"},{"cvss_score":9.8,"headline":"Apache Airflow: Privilege escalation using airflow logs","id":"CVE-2023-25754","kev_date_added":null,"published":"2023-05-08"},{"cvss_score":9.8,"headline":"Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow","id":"CVE-2023-22884","kev_date_added":null,"published":"2023-01-21"},{"cvss_score":9.8,"headline":"Apache Airflow Pinot provider allowed Command Injection","id":"CVE-2022-38649","kev_date_added":null,"published":"2022-11-22"},{"cvss_score":9.8,"headline":"Apache Airlfow Pig Provider RCE","id":"CVE-2022-40189","kev_date_added":null,"published":"2022-11-22"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-13","vendors":["Apache Software Foundation"]},"summary":"An authenticated attacker can inject malicious links during provider installation in Apache Airflow, potentially leading to cross-site scripting attacks.","url":"https://insights.sbomify.com/CVE-2024-39863/"}