# CVE-2024-39877: Apache Airflow: DAG Author Code Execution possibility in airflow-scheduler

> Authenticated DAG authors can execute arbitrary code in the scheduler context via crafted doc_md parameters, requiring an upgrade to secure the system.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2024
- **Updated:** 13 Sep 2024
- **Also known as:** BIT-airflow-2024-39877, ECHO-f127-5150-e1e6, GHSA-g5hv-r743-v8pm, PYSEC-2024-190

## What is CVE-2024-39877?

CVE-2024-39877 is a high-severity code injection vulnerability in Apache Airflow, published on 17 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.

Weakness: CWE-277 (Insecure Inherited Permissions), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-39877?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | From 2.4.0 | 2.9.3 |
| `apache-airflow` | PyPI | From 2.4.0 | 2.9.3 |
| `apache-airflow` | PyPI | From 2.4.0 | 2.9.3 |
| `airflow` | Bitnami | From 2.4.0 | 2.9.3 |

Products: Apache Airflow.

## How do I fix CVE-2024-39877?

Upgrade apache-airflow to 2.9.3 or later.

## Is CVE-2024-39877 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-39877 exists.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39877 and fix it if it is affected.

What it is: CVE-2024-39877 is a high-severity code injection vulnerability in Apache Airflow, published on 17 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-39877 exists.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected from 2.4.0; fixed in 2.9.3
- apache-airflow (PyPI): affected from 2.4.0; fixed in 2.9.3
- apache-airflow (PyPI): affected from 2.4.0; fixed in 2.9.3
- airflow (Bitnami): affected from 2.4.0; fixed in 2.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39877/ (Markdown: https://insights.sbomify.com/CVE-2024-39877/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39877
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39877
- OSV: https://osv.dev/vulnerability/CVE-2024-39877

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39877/
Summaries are generated and may contain mistakes; the official description above is the record.
