{"answers":{"affected":"1 open source package ship an affected version, including apache. It affects 2 products.","exploited":"There is no known exploitation of CVE-2024-39884 in the wild and no public exploit code.","fix":"Upgrade apache to 2.4.61 or later.","what":"CVE-2024-39884 is a medium-severity vulnerability in Apache Http Server, published on 4 Jul 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-39884 and fix it if it is affected.\n\nWhat it is: CVE-2024-39884 is a medium-severity vulnerability in Apache Http Server, published on 4 Jul 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-39884 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache (Bitnami): affected from 2.4.60; fixed in 2.4.61\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-39884/ (Markdown: https://insights.sbomify.com/CVE-2024-39884/index.md)","id":"CVE-2024-39884","markdown":"https://insights.sbomify.com/CVE-2024-39884/index.md","name":"CVE-2024-39884","record":{"aliases":["ALPINE-CVE-2024-39884","AZL-43170","AZL-43174","BIT-apache-2024-39884","CLEANSTART-2026-CF08389","DEBIAN-CVE-2024-39884","GHSA-5r34-776f-3434","SUSE-SU-2024:3061-1","UBUNTU-CVE-2024-39884"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Apache HTTP Server","requires_auth":"none","summary":"Attackers can view source code of scripts like PHP due to a regression in handler configuration, affecting Apache HTTP Server users.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"http_server","vendor":"apache"},{"product":"ontap_tools","vendor":"netapp"}],"cvss":{"score":6.2,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[],"description":"A regression in the core of Apache HTTP Server 2.4.60 ignores some use of the legacy content-type based configuration of handlers.   \"AddType\" and similar configuration, under some circumstances where files are requested indirectly, result in source code disclosure of local content. For example, PHP scripts may be served instead of interpreted.\n\nUsers are recommended to upgrade to version 2.4.61, which fixes this issue.","ecosystems":["Bitnami","SUSE:Linux Enterprise Server 12 SP5","SUSE:Linux Enterprise Server for SAP Applications 12 SP5","SUSE:Linux Enterprise Software Development Kit 12 SP5"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache HTTP Server: source code disclosure with handlers configured via AddType","id":"CVE-2024-39884","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:http_server","products":["apache:http_server"],"type":"information_disclosure","year":"2024"},"n_packages":7,"n_references":3,"next":{"headline":"Information disclosure in TONE store App","id":"CVE-2024-39886"},"packages":[{"ecosystem":"Bitnami","fixed":["2.4.61"],"introduced":["2.4.60"],"last_affected":[],"package":"apache","purl":"pkg:bitnami/apache","source":"BIT-apache-2024-39884"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP5","fixed":["2.4.51-35.60.1"],"introduced":["0"],"last_affected":[],"package":"apache2","purl":"pkg:rpm/suse/apache2\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP5","source":"SUSE-SU-2024:3061-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP5","fixed":["2.4.51-35.60.1"],"introduced":["0"],"last_affected":[],"package":"apache2-tls13","purl":"pkg:rpm/suse/apache2-tls13\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP5","source":"SUSE-SU-2024:3061-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP5","fixed":["2.4.51-35.60.1"],"introduced":["0"],"last_affected":[],"package":"apache2","purl":"pkg:rpm/suse/apache2\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP5","source":"SUSE-SU-2024:3061-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP5","fixed":["2.4.51-35.60.1"],"introduced":["0"],"last_affected":[],"package":"apache2-tls13","purl":"pkg:rpm/suse/apache2-tls13\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP5","source":"SUSE-SU-2024:3061-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP5","fixed":["2.4.51-35.60.1"],"introduced":["0"],"last_affected":[],"package":"apache2","purl":"pkg:rpm/suse/apache2\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP5","source":"SUSE-SU-2024:3061-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP5","fixed":["2.4.51-35.60.1"],"introduced":["0"],"last_affected":[],"package":"apache2-tls13","purl":"pkg:rpm/suse/apache2-tls13\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP5","source":"SUSE-SU-2024:3061-1"}],"prev":{"headline":"Heap-based Buffer Overflow in Delta Electronics CNCSoft-G2","id":"CVE-2024-39883"},"products":["Apache HTTP Server"],"published":"2024-07-04","related":[{"cvss_score":9.8,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-42013","kev_date_added":"2021-11-03","published":"2021-10-07"},{"cvss_score":9.1,"headline":"Apache HTTP Server Improper Escaping of Output","id":"CVE-2024-38475","kev_date_added":"2025-05-01","published":"2024-07-01"},{"cvss_score":9,"headline":"Apache HTTP Server-Side Request Forgery (SSRF)","id":"CVE-2021-40438","kev_date_added":"2021-12-01","published":"2021-09-16"},{"cvss_score":7.8,"headline":"Apache HTTP Server Privilege Escalation","id":"CVE-2019-0211","kev_date_added":"2021-11-03","published":"2019-04-08"},{"cvss_score":7.5,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-41773","kev_date_added":"2021-11-03","published":"2021-10-05"},{"cvss_score":10,"headline":"Use after free in n/a","id":"CVE-2010-0425","kev_date_added":null,"published":"2010-03-05"},{"cvss_score":10,"headline":"Auth bypass in n/a","id":"CVE-2005-2700","kev_date_added":null,"published":"2005-09-06"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Apache Software Foundation"]},"summary":"Attackers can view source code of scripts like PHP due to a regression in handler configuration, affecting Apache HTTP Server users.","url":"https://insights.sbomify.com/CVE-2024-39884/"}