# CVE-2024-39884: Apache HTTP Server: source code disclosure with handlers configured via AddType

> Attackers can view source code of scripts like PHP due to a regression in handler configuration, affecting Apache HTTP Server users.

- **Severity:** Medium 6.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jul 2024
- **Updated:** 13 Feb 2025
- **Also known as:** ALPINE-CVE-2024-39884, AZL-43170, AZL-43174, BIT-apache-2024-39884, CLEANSTART-2026-CF08389, DEBIAN-CVE-2024-39884, GHSA-5r34-776f-3434, SUSE-SU-2024:3061-1, UBUNTU-CVE-2024-39884

## What is CVE-2024-39884?

CVE-2024-39884 is a medium-severity vulnerability in Apache Http Server, published on 4 Jul 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A regression in the core of Apache HTTP Server 2.4.60 ignores some use of the legacy content-type based configuration of handlers.   "AddType" and similar configuration, under some circumstances where files are requested indirectly, result in source code disclosure of local content. For example, PHP scripts may be served instead of interpreted.

Users are recommended to upgrade to version 2.4.61, which fixes this issue.

## Which versions are affected by CVE-2024-39884?

1 open source package ship an affected version, including apache. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.60 | 2.4.61 |
| `apache2` | SUSE:Linux Enterprise Server 12 SP5 | All versions | 2.4.51-35.60.1 |
| `apache2-tls13` | SUSE:Linux Enterprise Server 12 SP5 | All versions | 2.4.51-35.60.1 |
| `apache2` | SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 2.4.51-35.60.1 |
| `apache2-tls13` | SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 2.4.51-35.60.1 |
| `apache2` | SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 2.4.51-35.60.1 |
| `apache2-tls13` | SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 2.4.51-35.60.1 |

Products: Apache Http Server, Netapp Ontap Tools.

## How do I fix CVE-2024-39884?

Upgrade apache to 2.4.61 or later.

## Is CVE-2024-39884 being exploited?

There is no known exploitation of CVE-2024-39884 in the wild and no public exploit code.

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39884 and fix it if it is affected.

What it is: CVE-2024-39884 is a medium-severity vulnerability in Apache Http Server, published on 4 Jul 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-39884 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.60; fixed in 2.4.61

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39884/ (Markdown: https://insights.sbomify.com/CVE-2024-39884/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39884
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39884
- OSV: https://osv.dev/vulnerability/CVE-2024-39884

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39884/
Summaries are generated and may contain mistakes; the official description above is the record.
