CVE-2024-39887 Apache Superset: Improper SQL authorisation, parse not checking for specific engine functions

Medium 4.3 Published Updated

Attackers can bypass SQL authorization in Apache Superset by exploiting unchecked engine-specific functions, potentially accessing unauthorized data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-39887?

CVE-2024-39887 is a medium-severity SQL injection vulnerability in Apache Superset, published on 16 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An SQL Injection vulnerability in Apache Superset exists due to improper neutralization of special elements used in SQL commands. Specifically, certain engine-specific functions are not checked, which allows attackers to bypass Apache Superset's SQL authorization. To mitigate this, a new configuration key named DISALLOWED_SQL_FUNCTIONS has been introduced. This key disallows the use of the following PostgreSQL functions: version, query_to_xml, inet_server_addr, and inet_client_addr. Additional functions can be added to this list for increased protection.

This issue affects Apache Superset: before 4.0.2.

Users are recommended to upgrade to version 4.0.2, which fixes the issue.

Weakness: CWE-89

Which versions are affected by CVE-2024-39887?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.

PackageAffectedFixed in
apache-superset PyPIAll versions4.0.2
apache-superset PyPIAll versions4.0.2
apache-superset PyPIAll versions4.0.2
superset BitnamiAll versions4.1.1

Products include Apache Superset.

How do I fix CVE-2024-39887?

Upgrade apache-superset to 4.0.2 or later.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2024-39887 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-39887 exists.

Public exploit code: 1 Nuclei template.

All Apache Superset vulnerabilities

Sources

Also known as BIT-superset-2024-39887, GHSA-2q6j-vpvr-6pvj, PYSEC-2026-1155.

Is CVE-2024-39887 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free