# CVE-2024-39887: Apache Superset: Improper SQL authorisation, parse not checking for specific engine functions

> Attackers can bypass SQL authorization in Apache Superset by exploiting unchecked engine-specific functions, potentially accessing unauthorized data.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jul 2024
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-superset-2024-39887, GHSA-2q6j-vpvr-6pvj, PYSEC-2026-1155

## What is CVE-2024-39887?

CVE-2024-39887 is a medium-severity SQL injection vulnerability in Apache Superset, published on 16 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An SQL Injection vulnerability in Apache Superset exists due to improper neutralization of special elements used in SQL commands. Specifically, certain engine-specific functions are not checked, which allows attackers to bypass Apache Superset's SQL authorization. To mitigate this, a new configuration key named DISALLOWED_SQL_FUNCTIONS has been introduced. This key disallows the use of the following PostgreSQL functions: version, query_to_xml, inet_server_addr, and inet_client_addr. Additional functions can be added to this list for increased protection.

This issue affects Apache Superset: before 4.0.2.

Users are recommended to upgrade to version 4.0.2, which fixes the issue.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2024-39887?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | All versions | 4.0.2 |
| `apache-superset` | PyPI | All versions | 4.0.2 |
| `apache-superset` | PyPI | All versions | 4.0.2 |
| `superset` | Bitnami | All versions | 4.1.1 |

Products: Apache Superset.

## How do I fix CVE-2024-39887?

Upgrade apache-superset to 4.0.2 or later.

## Is CVE-2024-39887 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-39887 exists.

Public exploit code:

- Apache Superset < 4.0.2 - SQL Injection (nuclei): http/cves/2024/CVE-2024-39887.yaml

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39887 and fix it if it is affected.

What it is: CVE-2024-39887 is a medium-severity SQL injection vulnerability in Apache Superset, published on 16 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-39887 exists.

Affected packages and fixed versions:
- apache-superset (PyPI): affected all versions; fixed in 4.0.2
- apache-superset (PyPI): affected all versions; fixed in 4.0.2
- apache-superset (PyPI): affected all versions; fixed in 4.0.2
- superset (Bitnami): affected all versions; fixed in 4.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39887/ (Markdown: https://insights.sbomify.com/CVE-2024-39887/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39887
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39887
- OSV: https://osv.dev/vulnerability/CVE-2024-39887

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39887/
Summaries are generated and may contain mistakes; the official description above is the record.
