# CVE-2024-39896: Directus allows SSO User Enumeration

> Attackers can enumerate existing SSO users by observing specific error messages when attempting local authentication with SSO-linked emails.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-jgf4-vwc3-r46v

## What is CVE-2024-39896?

CVE-2024-39896 is a high-severity vulnerability in Monospace Directus, published on 8 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Directus is a real-time API and App dashboard for managing SQL database content. When relying on SSO providers in combination with local authentication it can be possible to enumerate existing SSO users in the instance. This is possible because if an email address exists in Directus and belongs to a known SSO provider then it will throw a "helpful" error that the user belongs to another provider. This vulnerability is fixed in 10.13.0.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-39896?

2 open source packages ship an affected version, including directus. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `directus` | npm | From 9.11 | 10.13.0 |
| `directus` | npm | From 9.11 | 10.13.0 |

Products: Monospace Directus.

## How do I fix CVE-2024-39896?

Upgrade directus to 10.13.0 or later.

## Is CVE-2024-39896 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-39896 exists.

## Other vulnerabilities in Monospace Directus

- [CVE-2022-26969](https://insights.sbomify.com/CVE-2022-26969/): Insecure default value for CORS configuration (critical 9.8)
- [CVE-2025-55746](https://insights.sbomify.com/CVE-2025-55746/): Directus allows unauthenticated file upload and file modification due to lacking input sanitization (critical 9.3)
- [CVE-2026-35408](https://insights.sbomify.com/CVE-2026-35408/): Directus is Missing Cross-Origin Opener Policy (high 8.7)
- [CVE-2026-61836](https://insights.sbomify.com/CVE-2026-61836/): Directus: Authorization-dependent response served from unsegmented cache key (high 8.6)
- [CVE-2025-30353](https://insights.sbomify.com/CVE-2025-30353/): Directus's webhook trigger flows can leak sensitive data (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39896 and fix it if it is affected.

What it is: CVE-2024-39896 is a high-severity vulnerability in Monospace Directus, published on 8 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-39896 exists.

Affected packages and fixed versions:
- directus (npm): affected from 9.11; fixed in 10.13.0
- directus (npm): affected from 9.11; fixed in 10.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39896/ (Markdown: https://insights.sbomify.com/CVE-2024-39896/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39896
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39896
- OSV: https://osv.dev/vulnerability/CVE-2024-39896

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39896/
Summaries are generated and may contain mistakes; the official description above is the record.
