# CVE-2024-39901: OpenSearch Observability does not properly restrict access to private tenant resources

> Attackers can access private tenant resources like notebooks without proper authorization checks, leading to data disclosure in OpenSearch Observability.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-77vc-rj32-2r33

## What is CVE-2024-39901?

CVE-2024-39901 is a medium-severity missing authorization vulnerability in opensearch-project observability, published on 9 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenSearch Observability is collection of plugins and applications that visualize data-driven events. An issue in the OpenSearch observability plugins allows unintended access to private tenant resources like notebooks. The system did not properly check if the user was the resource author when accessing resources in a private tenant, leading to potential data being revealed. The patches are included in OpenSearch 2.14.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2024-39901?

2 open source packages ship an affected version, including org.opensearch.plugin:opensearch-observability. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opensearch.plugin:opensearch-observability` | Maven | All versions | 2.14.0.0 |
| `org.opensearch.plugin:opensearch-observability` | Maven | All versions | 2.14.0.0 |

Products: Opensearch Observability.

## How do I fix CVE-2024-39901?

Upgrade org.opensearch.plugin:opensearch-observability to 2.14.0.0 or later.

## Is CVE-2024-39901 being exploited?

There is no known exploitation of CVE-2024-39901 in the wild and no public exploit code.

## Other vulnerabilities in opensearch-project observability

- [CVE-2024-39900](https://insights.sbomify.com/CVE-2024-39900/): OpenSearch Dashboards Reports does not properly restrict access to private tenant resources (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39901 and fix it if it is affected.

What it is: CVE-2024-39901 is a medium-severity missing authorization vulnerability in opensearch-project observability, published on 9 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-39901 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.opensearch.plugin:opensearch-observability (Maven): affected all versions; fixed in 2.14.0.0
- org.opensearch.plugin:opensearch-observability (Maven): affected all versions; fixed in 2.14.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39901/ (Markdown: https://insights.sbomify.com/CVE-2024-39901/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39901
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39901
- OSV: https://osv.dev/vulnerability/CVE-2024-39901

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39901/
Summaries are generated and may contain mistakes; the official description above is the record.
