# CVE-2024-39903: Local File Inclusion in Solara

> Attackers can read arbitrary local files by exploiting a path traversal flaw in Solara's static file serving mechanism.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-9794-pc4r-438w, PYSEC-2026-1933

## What is CVE-2024-39903?

CVE-2024-39903 is a high-severity path traversal vulnerability in widgetti solara, published on 12 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Solara is a pure Python, React-style framework for scaling Jupyter and web apps. A Local File Inclusion (LFI) vulnerability was identified in widgetti/solara, in version <1.35.1, which was fixed in version 1.35.1. This vulnerability arises from the application's failure to properly validate URI fragments for directory traversal sequences such as '../' when serving static files. An attacker can exploit this flaw by manipulating the fragment part of the URI to read arbitrary files on the local file system.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-39903?

3 open source packages ship an affected version, including solara. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `solara` | PyPI | All versions | 1.35.1 |
| `solara` | PyPI | All versions | 1.35.1 |
| `solara` | PyPI | All versions | 1.35.1 |

Products: Widgetti Solara.

## How do I fix CVE-2024-39903?

Upgrade solara to 1.35.1 or later.

## Is CVE-2024-39903 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-39903 exists.

Public exploit code:

- Solara <1.35.1 - Local File Inclusion (nuclei): http/cves/2024/CVE-2024-39903.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39903 and fix it if it is affected.

What it is: CVE-2024-39903 is a high-severity path traversal vulnerability in widgetti solara, published on 12 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-39903 exists.

Affected packages and fixed versions:
- solara (PyPI): affected all versions; fixed in 1.35.1
- solara (PyPI): affected all versions; fixed in 1.35.1
- solara (PyPI): affected all versions; fixed in 1.35.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39903/ (Markdown: https://insights.sbomify.com/CVE-2024-39903/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39903
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39903
- OSV: https://osv.dev/vulnerability/CVE-2024-39903

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39903/
Summaries are generated and may contain mistakes; the official description above is the record.
