{"answers":{"affected":"2 open source packages ship an affected version, including rexml. It affects 2 products.","exploited":"There is no known exploitation of CVE-2024-39908 in the wild and no public exploit code.","fix":"Upgrade rexml to 3.3.2 or later.","what":"CVE-2024-39908 is a medium-severity denial of service vulnerability in Netapp Bootstrap Os, published on 16 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-39908 and fix it if it is affected.\n\nWhat it is: CVE-2024-39908 is a medium-severity denial of service vulnerability in Netapp Bootstrap Os, published on 16 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-39908 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rexml (RubyGems): affected all versions; fixed in 3.3.2\n- rexml (RubyGems): affected all versions; fixed in 3.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-39908/ (Markdown: https://insights.sbomify.com/CVE-2024-39908/index.md)","id":"CVE-2024-39908","markdown":"https://insights.sbomify.com/CVE-2024-39908/index.md","name":"CVE-2024-39908","record":{"aliases":["ALPINE-CVE-2024-39908","AZL-45429","AZL-45435","AZL-45439","AZL-45769","BELL-CVE-2024-39908","DEBIAN-CVE-2024-39908","ECHO-b0cc-a0a5-6bba","GHSA-4xqq-m2hx-25v8","MINI-p67c-crcr-v7f6","UBUNTU-CVE-2024-39908"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby XML library","requires_auth":"none","summary":"Attackers can cause denial of service in Ruby applications by sending XML with specific characters, requiring an upgrade to the REXML library.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"bootstrap_os","vendor":"netapp"},{"product":"rexml","vendor":"ruby-lang"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"REXML is an XML toolkit for Ruby. The REXML gem before 3.3.1 has some DoS vulnerabilities when it parses an XML that has many specific characters such as `\u003c`, `0` and `%\u003e`. If you need to parse untrusted XMLs, you many be impacted to these vulnerabilities. The REXML gem 3.3.2 or later include the patches to fix these vulnerabilities. Users are advised to upgrade. Users unable to upgrade should avoid parsing untrusted XML strings.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":"2024-12-19","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-12-19T18:59:52Z","kind":"github_poc","ref":"https://github.com/SpiralBL0CK/CVE-2024-39908","stars":0,"title":"CVE-2024-39908 full poc"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Denial of service in REXML","id":"CVE-2024-39908","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"netapp:bootstrap_os","products":["netapp:bootstrap_os"],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"SQL Injection in the KubeClarity REST API","id":"CVE-2024-39909"},"packages":[{"ecosystem":"RubyGems","fixed":["3.3.2"],"introduced":["0"],"last_affected":[],"package":"rexml","purl":null,"source":"GHSA-4xqq-m2hx-25v8"},{"ecosystem":"RubyGems","fixed":["3.3.2"],"introduced":["0"],"last_affected":[],"package":"rexml","purl":"pkg:gem/rexml","source":"GHSA-4xqq-m2hx-25v8"}],"prev":{"headline":"a sqlinjection in 1Panel","id":"CVE-2024-39907"},"products":["rexml"],"published":"2024-07-16","related":[{"cvss_score":5.9,"headline":"REXML denial of service vulnerability","id":"CVE-2024-43398","kev_date_added":null,"published":"2024-08-22"},{"cvss_score":4.8,"headline":"Security feature bypass in Oracle Java SE","id":"CVE-2025-30691","kev_date_added":null,"published":"2025-04-15"},{"cvss_score":4.5,"headline":"heap-buffer-overflow in do_search() in Vim \u003c 9.1.0689","id":"CVE-2024-43790","kev_date_added":null,"published":"2024-08-22"},{"cvss_score":4.4,"headline":"Vim vulnerable to potential data loss with zip.vim and special crafted zip files","id":"CVE-2025-29768","kev_date_added":null,"published":"2025-03-13"},{"cvss_score":3.9,"headline":"use-after-free when closing buffers in Vim","id":"CVE-2024-47814","kev_date_added":null,"published":"2024-10-07"},{"cvss_score":3.7,"headline":"Other in GraalVM","id":"CVE-2024-21211","kev_date_added":null,"published":"2024-10-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["ruby"]},"summary":"Attackers can cause denial of service in Ruby applications by sending XML with specific characters, requiring an upgrade to the REXML library.","url":"https://insights.sbomify.com/CVE-2024-39908/"}