# CVE-2024-39908: Denial of service in REXML

> Attackers can cause denial of service in Ruby applications by sending XML with specific characters, requiring an upgrade to the REXML library.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Jul 2024
- **Updated:** 3 Nov 2025
- **Also known as:** ALPINE-CVE-2024-39908, AZL-45429, AZL-45435, AZL-45439, AZL-45769, BELL-CVE-2024-39908, DEBIAN-CVE-2024-39908, ECHO-b0cc-a0a5-6bba, GHSA-4xqq-m2hx-25v8, MINI-p67c-crcr-v7f6, UBUNTU-CVE-2024-39908

## What is CVE-2024-39908?

CVE-2024-39908 is a medium-severity denial of service vulnerability in Netapp Bootstrap Os, published on 16 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

REXML is an XML toolkit for Ruby. The REXML gem before 3.3.1 has some DoS vulnerabilities when it parses an XML that has many specific characters such as `<`, `0` and `%>`. If you need to parse untrusted XMLs, you many be impacted to these vulnerabilities. The REXML gem 3.3.2 or later include the patches to fix these vulnerabilities. Users are advised to upgrade. Users unable to upgrade should avoid parsing untrusted XML strings.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-39908?

2 open source packages ship an affected version, including rexml. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rexml` | RubyGems | All versions | 3.3.2 |
| `rexml` | RubyGems | All versions | 3.3.2 |

Products: Netapp Bootstrap Os, Ruby-Lang Rexml.

## How do I fix CVE-2024-39908?

Upgrade rexml to 3.3.2 or later.

## Is CVE-2024-39908 being exploited?

There is no known exploitation of CVE-2024-39908 in the wild and no public exploit code.

Public exploit code:

- CVE-2024-39908 full poc (github_poc): https://github.com/SpiralBL0CK/CVE-2024-39908

## Other vulnerabilities in Netapp Bootstrap Os

- [CVE-2024-43398](https://insights.sbomify.com/CVE-2024-43398/): REXML denial of service vulnerability (medium 5.9)
- [CVE-2025-30691](https://insights.sbomify.com/CVE-2025-30691/): Security feature bypass in Oracle Java SE (medium 4.8)
- [CVE-2024-43790](https://insights.sbomify.com/CVE-2024-43790/): heap-buffer-overflow in do_search() in Vim < 9.1.0689 (medium 4.5)
- [CVE-2025-29768](https://insights.sbomify.com/CVE-2025-29768/): Vim vulnerable to potential data loss with zip.vim and special crafted zip files (medium 4.4)
- [CVE-2024-47814](https://insights.sbomify.com/CVE-2024-47814/): use-after-free when closing buffers in Vim (low 3.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39908 and fix it if it is affected.

What it is: CVE-2024-39908 is a medium-severity denial of service vulnerability in Netapp Bootstrap Os, published on 16 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-39908 in the wild and no public exploit code.

Affected packages and fixed versions:
- rexml (RubyGems): affected all versions; fixed in 3.3.2
- rexml (RubyGems): affected all versions; fixed in 3.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39908/ (Markdown: https://insights.sbomify.com/CVE-2024-39908/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39908
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39908
- OSV: https://osv.dev/vulnerability/CVE-2024-39908

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39908/
Summaries are generated and may contain mistakes; the official description above is the record.
