# CVE-2024-39910: Cross-site scripting (XSS) in the decidim admin panel with QuillJS WYSWYG editor

> Attackers can inject malicious scripts via the QuillJS editor in the admin panel, potentially leading to code execution or account takeover.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Sep 2024
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-vvqw-fqwx-mqmm

## What is CVE-2024-39910?

CVE-2024-39910 is a medium-severity cross-site scripting vulnerability in decidim, published on 16 Sep 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

decidim is a Free Open-Source participatory democracy, citizen participation and open government for cities and organizations. The WYSWYG editor QuillJS is subject to potential XSS attach in case the attacker manages to modify the HTML before being uploaded to the server. The attacker is able to change e.g. to <svg onload=alert('XSS')> if they know how to craft these requests themselves. This issue has been addressed in release version 0.27.7. All users are advised to upgrade. Users unable to upgrade should review the user accounts that have access to the admin panel (i.e. general Administrators, and participatory space's Administrators) and remove access to them if they don't need it. Disable the "Enable rich text editor for participants" setting in the admin dashboard

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-39910?

2 open source packages ship an affected version, including decidim. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `decidim` | RubyGems | All versions | 0.27.7 |
| `decidim` | RubyGems | All versions | 0.27.7 |

Products: Decidim Decidim.

## How do I fix CVE-2024-39910?

Upgrade decidim to 0.27.7 or later.

## Is CVE-2024-39910 being exploited?

There is no known exploitation of CVE-2024-39910 in the wild and no public exploit code.

## Other vulnerabilities in decidim

- [CVE-2026-23891](https://insights.sbomify.com/CVE-2026-23891/): Decidim has a Cross-site scripting (XSS) vulnerability via user name field (critical 9.3)
- [CVE-2023-36465](https://insights.sbomify.com/CVE-2023-36465/): Decidim has broken access control in templates (critical 9.1)
- [CVE-2025-65017](https://insights.sbomify.com/CVE-2025-65017/): Decidim's private data exports can lead to data leaks (high 8.2)
- [CVE-2023-32693](https://insights.sbomify.com/CVE-2023-32693/): Decidim Cross-site Scripting vulnerability in the external link redirections (high 8.1)
- [CVE-2023-34089](https://insights.sbomify.com/CVE-2023-34089/): Decidim Cross-site Scripting vulnerability in the processes filter (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39910 and fix it if it is affected.

What it is: CVE-2024-39910 is a medium-severity cross-site scripting vulnerability in decidim, published on 16 Sep 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-39910 in the wild and no public exploit code.

Affected packages and fixed versions:
- decidim (RubyGems): affected all versions; fixed in 0.27.7
- decidim (RubyGems): affected all versions; fixed in 0.27.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39910/ (Markdown: https://insights.sbomify.com/CVE-2024-39910/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39910
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39910
- OSV: https://osv.dev/vulnerability/CVE-2024-39910

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39910/
Summaries are generated and may contain mistakes; the official description above is the record.
