# CVE-2024-39912: Enumeration of valid usernames in web-auth/webauthn-lib

> Attackers can enumerate valid usernames in applications using this WebAuthn library, facilitating targeted attacks against specific accounts.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-875x-g8p7-5w27

## What is CVE-2024-39912?

CVE-2024-39912 is a medium-severity vulnerability in web-auth webauthn-framework, published on 15 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

web-auth/webauthn-lib is an open source set of PHP libraries and a Symfony bundle to allow developers to integrate that authentication mechanism into their web applications. The ProfileBasedRequestOptionsBuilder method returns allowedCredentials without any credentials if no username was found. When WebAuthn is used as the first or only authentication method, an attacker can enumerate usernames based on the absence of the `allowedCredentials` property in the assertion options response. This allows enumeration of valid or invalid usernames. By knowing which usernames are valid, attackers can focus their efforts on a smaller set of potential targets, increasing the efficiency and likelihood of successful attacks. This issue has been addressed in version 4.9.0 and all users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-204 (Observable Response Discrepancy)

## Which versions are affected by CVE-2024-39912?

4 open source packages ship an affected version, including web-auth/webauthn-framework and web-auth/webauthn-lib.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `web-auth/webauthn-framework` | Packagist | From 4.5.0 | 4.9.0 |
| `web-auth/webauthn-framework` | Packagist | From 4.5.0 | 4.9.0 |
| `web-auth/webauthn-lib` | Packagist | From 4.5.0 | 4.9.0 |
| `web-auth/webauthn-lib` | Packagist | From 4.5.0 | 4.9.0 |

## How do I fix CVE-2024-39912?

Upgrade web-auth/webauthn-framework to 4.9.0 or later.

## Is CVE-2024-39912 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-39912 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39912 and fix it if it is affected.

What it is: CVE-2024-39912 is a medium-severity vulnerability in web-auth webauthn-framework, published on 15 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-39912 exists.

Affected packages and fixed versions:
- web-auth/webauthn-framework (Packagist): affected from 4.5.0; fixed in 4.9.0
- web-auth/webauthn-framework (Packagist): affected from 4.5.0; fixed in 4.9.0
- web-auth/webauthn-lib (Packagist): affected from 4.5.0; fixed in 4.9.0
- web-auth/webauthn-lib (Packagist): affected from 4.5.0; fixed in 4.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39912/ (Markdown: https://insights.sbomify.com/CVE-2024-39912/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39912
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39912
- OSV: https://osv.dev/vulnerability/CVE-2024-39912

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39912/
Summaries are generated and may contain mistakes; the official description above is the record.
