# CVE-2024-39917: xrdp allows an ininite number of login attempts

> Attackers can bypass login attempt limits in xrdp, enabling unlimited brute-force attacks against user accounts.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jul 2024
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2024-39917, GHSA-7w22-h4w7-8j5j, MGASA-2025-0044, SUSE-SU-2025:0335-1, SUSE-SU-2025:0336-1, SUSE-SU-2025:0350-1, UBUNTU-CVE-2024-39917

## What is CVE-2024-39917?

CVE-2024-39917 is a high-severity vulnerability in neutrinolabs xrdp, published on 12 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

xrdp is an open source RDP server. xrdp versions prior to 0.10.0 have a vulnerability that allows attackers to make an infinite number of login attempts. The number of max login attempts is supposed to be  limited by a configuration parameter `MaxLoginRetry` in `/etc/xrdp/sesman.ini`. However, this mechanism was not effectively working. As a result, xrdp allows an infinite number of login attempts.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2024-39917?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `xrdp` | SUSE:Enterprise Storage 7.1 | All versions | 0.9.13.1-150200.4.33.1 |
| `xrdp` | SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 0.9.13.1-150200.4.33.1 |
| `xrdp` | SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 0.9.13.1-150200.4.33.1 |
| `xrdp` | SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 0.9.13.1-150200.4.33.1 |
| `xrdp` | SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 0.9.13.1-150200.4.33.1 |
| `xrdp` | SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | All versions | 0.9.13.1-150200.4.33.1 |
| `xrdp` | SUSE:Linux Enterprise Module for Basesystem 15 SP6 | All versions | 0.9.13.1-150600.15.3.1 |
| `xrdp` | SUSE:Linux Enterprise Server 12 SP5-LTSS | All versions | 0.9.10-3.19.1 |
| `xrdp` | SUSE:Linux Enterprise Server 15 SP3-LTSS | All versions | 0.9.13.1-150200.4.33.1 |
| `xrdp` | SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 0.9.13.1-150200.4.33.1 |
| `xrdp` | SUSE:Linux Enterprise Server 15 SP5-LTSS | All versions | 0.9.13.1-150200.4.33.1 |
| `xrdp` | SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 0.9.10-3.19.1 |
| `xrdp` | SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | All versions | 0.9.13.1-150200.4.33.1 |
| `xrdp` | SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 0.9.13.1-150200.4.33.1 |
| `xrdp` | SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | All versions | 0.9.13.1-150200.4.33.1 |
| `xrdp` | SUSE:Manager Proxy 4.3 | All versions | 0.9.13.1-150200.4.33.1 |
| `xrdp` | SUSE:Manager Server 4.3 | All versions | 0.9.13.1-150200.4.33.1 |
| `xrdp` | openSUSE:Leap 15.6 | All versions | 0.9.13.1-150600.15.3.1 |

Products: Neutrinolabs Xrdp.

## How do I fix CVE-2024-39917?

Upgrade to a fixed version.

## Is CVE-2024-39917 being exploited?

There is no known exploitation of CVE-2024-39917 in the wild and no public exploit code.

## Other vulnerabilities in neutrinolabs xrdp

- [CVE-2026-41252](https://insights.sbomify.com/CVE-2026-41252/): xrdp: lib_palette_update Heap Buffer Overflow & RCE (critical 9.8)
- [CVE-2026-32105](https://insights.sbomify.com/CVE-2026-32105/): xrdp: RDP MAC signature (dataSignature) never verified on receive — integrity bypass in non-TLS mode (critical 9.3)
- [CVE-2026-44178](https://insights.sbomify.com/CVE-2026-44178/): xrdp: Channel Data Forwarding Fixed-Size Buffer Overflow (high 8.8)
- [CVE-2026-32107](https://insights.sbomify.com/CVE-2026-32107/): xrdp: Fail-open privilege drop in sesexec — child processes may execute as root if setuid fails (high 8.8)
- [CVE-2026-33689](https://insights.sbomify.com/CVE-2026-33689/): xrdp: Pre-authentication out-of-bounds reads in channel parsers (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39917 and fix it if it is affected.

What it is: CVE-2024-39917 is a high-severity vulnerability in neutrinolabs xrdp, published on 12 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-39917 in the wild and no public exploit code.

Affected product: neutrinolabs xrdp. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39917/ (Markdown: https://insights.sbomify.com/CVE-2024-39917/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39917
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39917
- OSV: https://osv.dev/vulnerability/CVE-2024-39917

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39917/
Summaries are generated and may contain mistakes; the official description above is the record.
