CVE-2024-3992 Amen <= 3.3.1 - Admin+ Stored XSS

Medium 4.8 Published Updated

High-privilege users can inject malicious scripts into WordPress settings, enabling stored XSS attacks even in multisite environments.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-3992?

CVE-2024-3992 is a medium-severity cross-site scripting vulnerability in Unknown Amen, published on 14 Jun 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

The Amen WordPress plugin through 3.3.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

Weakness: CWE-79

Which versions are affected by CVE-2024-3992?

2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.

PackageAffectedFixed in
wordpress BitnamiAll versions3.3.2
wordpress-multisite BitnamiAll versions3.3.2

Products include Joshua Vandercar Amen.

How do I fix CVE-2024-3992?

Upgrade wordpress to 3.3.2 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-3992 being exploited?

There is no known exploitation of CVE-2024-3992 in the wild and no public exploit code.

Sources

Also known as BIT-wordpress-2024-3992, BIT-wordpress-multisite-2024-3992, GHSA-7fq6-6fhp-rwjm.

Is CVE-2024-3992 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free