CVE-2024-39928 Apache Linkis Spark EngineConn: Commons Lang's RandomStringUtils Random string security vulnerability

High 7.5 Published Updated

Weak random string generation in Apache Linkis Spark EngineConn tokens allows attackers to predict tokens and bypass security controls.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-39928?

CVE-2024-39928 is a high-severity vulnerability in Apache Linkis Spark EngineConn, published on 24 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

In Apache Linkis <= 1.5.0, a Random string security vulnerability in Spark EngineConn, random string generated by the Token when starting Py4j uses the Commons Lang's RandomStringUtils. Users are recommended to upgrade to version 1.6.0, which fixes this issue.

Weakness: CWE-326

Which versions are affected by CVE-2024-39928?

2 open source packages ship an affected version, including org.apache.linkis:linkis-engineplugin-spark. It affects 1 product.

PackageAffectedFixed in
org.apache.linkis:linkis-engineplugin-spark MavenAll versions1.6.0
org.apache.linkis:linkis-engineplugin-spark MavenAll versions1.6.0

Products include Apache Linkis.

How do I fix CVE-2024-39928?

Upgrade org.apache.linkis:linkis-engineplugin-spark to 1.6.0 or later.

Is CVE-2024-39928 being exploited?

There is no known exploitation of CVE-2024-39928 in the wild and no public exploit code.

Sources

Also known as GHSA-6gch-63wp-4v5f.

Is CVE-2024-39928 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free