# CVE-2024-39928: Apache Linkis Spark EngineConn: Commons Lang's RandomStringUtils Random string security vulnerability

> Weak random string generation in Apache Linkis Spark EngineConn tokens allows attackers to predict tokens and bypass security controls.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Sep 2024
- **Updated:** 24 Sep 2024
- **Also known as:** GHSA-6gch-63wp-4v5f

## What is CVE-2024-39928?

CVE-2024-39928 is a high-severity vulnerability in Apache Linkis Spark EngineConn, published on 24 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache Linkis <= 1.5.0, a Random string security vulnerability in Spark EngineConn, random string generated by the Token when starting Py4j uses the Commons Lang's RandomStringUtils.
Users are recommended to upgrade to version 1.6.0, which fixes this issue.

Weakness: CWE-326 (Inadequate Encryption Strength)

## Which versions are affected by CVE-2024-39928?

2 open source packages ship an affected version, including org.apache.linkis:linkis-engineplugin-spark. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.linkis:linkis-engineplugin-spark` | Maven | All versions | 1.6.0 |
| `org.apache.linkis:linkis-engineplugin-spark` | Maven | All versions | 1.6.0 |

Products: Apache Linkis.

## How do I fix CVE-2024-39928?

Upgrade org.apache.linkis:linkis-engineplugin-spark to 1.6.0 or later.

## Is CVE-2024-39928 being exploited?

There is no known exploitation of CVE-2024-39928 in the wild and no public exploit code.

## Other vulnerabilities in Apache Linkis Spark EngineConn

- [CVE-2023-27602](https://insights.sbomify.com/CVE-2023-27602/): Apache Linkis publicsercice module unrestricted upload of file (critical 9.8)
- [CVE-2023-27603](https://insights.sbomify.com/CVE-2023-27603/): Apache Linkis Mangaer module engineConn material upload exists Zip Slip issue (critical 9.8)
- [CVE-2023-29215](https://insights.sbomify.com/CVE-2023-29215/): Apache Linkis JDBC EngineCon has a deserialization command execution (critical 9.8)
- [CVE-2023-29216](https://insights.sbomify.com/CVE-2023-29216/): Apache Linkis DatasourceManager module has a deserialization command execution (critical 9.8)
- [CVE-2023-27987](https://insights.sbomify.com/CVE-2023-27987/): Apache Linkis gateway module token authentication bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39928 and fix it if it is affected.

What it is: CVE-2024-39928 is a high-severity vulnerability in Apache Linkis Spark EngineConn, published on 24 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-39928 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.linkis:linkis-engineplugin-spark (Maven): affected all versions; fixed in 1.6.0
- org.apache.linkis:linkis-engineplugin-spark (Maven): affected all versions; fixed in 1.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39928/ (Markdown: https://insights.sbomify.com/CVE-2024-39928/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39928
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39928
- OSV: https://osv.dev/vulnerability/CVE-2024-39928

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39928/
Summaries are generated and may contain mistakes; the official description above is the record.
