# CVE-2024-39930: Duplicate Advisory: github.com/gogs/gogs affected by CVE-2024-39930

> Authenticated attackers can achieve remote code execution via argument injection in the built-in SSH server if enabled.

- **Severity:** Critical 9.9 (`CVSS:3.1/AC:L/AV:N/A:H/C:H/I:H/PR:L/S:C/UI:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jul 2024
- **Updated:** 28 Aug 2024
- **Also known as:** GHSA-p69r-v3h4-rj4f, GHSA-vm62-9jw3-c8w3, GO-2024-2969

## What is CVE-2024-39930?

CVE-2024-39930 is a critical command injection vulnerability in n/a, published on 4 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The built-in SSH server of Gogs through 0.13.0 allows argument injection in internal/ssh/ssh.go, leading to remote code execution. Authenticated attackers can exploit this by opening an SSH connection and sending a malicious --split-string env request if the built-in SSH server is activated. Windows installations are unaffected.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2024-39930?

5 open source packages ship an affected version, including github.com/gogs/gogs and gogs.io/gogs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gogs/gogs` | Go | All versions | None |
| `github.com/gogs/gogs` | Go | All versions to 0.13.0 | None |
| `github.com/gogs/gogs` | Go | All versions to 0.13.0 | None |
| `gogs.io/gogs` | Go | All versions | 0.13.1 |
| `gogs.io/gogs` | Go | All versions | 0.13.1 |

Products: Gogs Gogs.

## How do I fix CVE-2024-39930?

Upgrade to a fixed version.

## Is CVE-2024-39930 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-39930 exists.

Public exploit code:

- Exploit Code for CVE-2024-39930 gogs ssh server RCE (github_poc): https://github.com/theMcSam/CVE-2024-39930-PoC
- gogs 0.13.0 - Remote Code Execution (RCE) (exploitdb)
- Gogs Under Attack: Unpacking the Critical SSH Vulnerability (CVE-2024–39930) (github_poc): https://github.com/alexander47777/-CVE-2024-39930
- https://github.com/laachy/CVE-2024-39930-ptrace-detection-mitigation (github_poc): https://github.com/laachy/CVE-2024-39930-ptrace-detection-mitigation

## Other vulnerabilities in n/a

- [CVE-2025-8110](https://insights.sbomify.com/CVE-2025-8110/): Gogs Path Traversal (high 8.7, exploited in the wild)
- [CVE-2024-56731](https://insights.sbomify.com/CVE-2024-56731/): Gogs deletion of internal files allows remote command execution (critical 10.0)
- [CVE-2022-1884](https://insights.sbomify.com/CVE-2022-1884/): Remote Command Execution in gogs/gogs (critical 10.0)
- [CVE-2022-1986](https://insights.sbomify.com/CVE-2022-1986/): OS Command Injection in gogs/gogs (critical 10.0)
- [CVE-2022-1992](https://insights.sbomify.com/CVE-2022-1992/): Path Traversal in gogs/gogs (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-39930 and fix it if it is affected.

What it is: CVE-2024-39930 is a critical command injection vulnerability in n/a, published on 4 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-39930 exists.

Affected packages and fixed versions:
- github.com/gogs/gogs (Go): affected all versions; no fix listed
- github.com/gogs/gogs (Go): affected all versions up to 0.13.0; no fix listed
- github.com/gogs/gogs (Go): affected all versions up to 0.13.0; no fix listed
- gogs.io/gogs (Go): affected all versions; fixed in 0.13.1
- gogs.io/gogs (Go): affected all versions; fixed in 0.13.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-39930/ (Markdown: https://insights.sbomify.com/CVE-2024-39930/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-39930
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-39930
- OSV: https://osv.dev/vulnerability/CVE-2024-39930

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-39930/
Summaries are generated and may contain mistakes; the official description above is the record.
