{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.eventmesh:eventmesh-runtime. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-39954 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-39954 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-39954 is a medium-severity server-side request forgery vulnerability in Apache EventMesh Runtime, published on 20 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-39954 and fix it if it is affected.\n\nWhat it is: CVE-2024-39954 is a medium-severity server-side request forgery vulnerability in Apache EventMesh Runtime, published on 20 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-39954 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.eventmesh:eventmesh-runtime (Maven): affected from 1.6.0-release up to 1.11.0-release; no fix listed\n- org.apache.eventmesh:eventmesh-runtime (Maven): affected from 1.6.0-release up to 1.11.0-release; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-39954/ (Markdown: https://insights.sbomify.com/CVE-2024-39954/index.md)","id":"CVE-2024-39954","markdown":"https://insights.sbomify.com/CVE-2024-39954/index.md","name":"CVE-2024-39954","record":{"aliases":["GHSA-hf86-8x8v-h7vc"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache EventMesh Runtime","requires_auth":"none","summary":"An attacker can exploit Server-Side Request Forgery in Apache EventMesh Runtime to read or update internal server resources.","user_interaction":"required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"eventmesh","vendor":"apache"}],"cvss":{"score":6.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"CWE-918 Server-Side Request Forgery (SSRF) in eventmesh-runtime module in WebhookUtil.java on windows\\linux\\mac os e.g. allows the attacker can abuse functionality on the server to read or update internal resources.\nUsers are recommended to upgrade to version 1.12.0 or use the master branch , which fixes this issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Apache EventMesh Runtime: SSRF","id":"CVE-2024-39954","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"ssrf","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"Command injection in n/a","id":"CVE-2024-39962"},"packages":[{"ecosystem":"Maven","fixed":[],"introduced":["1.6.0-release"],"last_affected":["1.11.0-release"],"package":"org.apache.eventmesh:eventmesh-runtime","purl":null,"source":"GHSA-hf86-8x8v-h7vc"},{"ecosystem":"Maven","fixed":[],"introduced":["1.6.0-release"],"last_affected":["1.11.0-release"],"package":"org.apache.eventmesh:eventmesh-runtime","purl":"pkg:maven/org.apache.eventmesh/eventmesh-runtime","source":"GHSA-hf86-8x8v-h7vc"}],"prev":{"headline":"Other in NVR4XXX and IPC-HX8XXX","id":"CVE-2024-39950"},"products":["Apache EventMesh Runtime"],"published":"2025-08-20","related":[{"cvss_score":9.8,"headline":"Apache EventMesh: raft Hessian Deserialization Vulnerability allowing remote code execution","id":"CVE-2024-56180","kev_date_added":null,"published":"2025-02-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-20","vendors":["Apache Software Foundation"]},"summary":"An attacker can exploit Server-Side Request Forgery in Apache EventMesh Runtime to read or update internal server resources.","url":"https://insights.sbomify.com/CVE-2024-39954/"}