CVE-2024-4006 Incorrect Authorization in GitLab
Attackers can bypass personal access token scopes in GraphQL subscriptions to read unauthorized data in GitLab.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-4006?
CVE-2024-4006 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 25 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 16.7 before 16.9.6, all versions starting from 16.10 before 16.10.4, all versions starting from 16.11 before 16.11.1 where personal access scopes were not honored by GraphQL subscriptions
Weakness: CWE-863
Which versions are affected by CVE-2024-4006?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 16.7.0 | 16.9.6, 16.10.4, 16.11.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-4006?
Upgrade gitlab to a fixed version for your release line: 16.9.6, 16.10.4 or 16.11.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-4006 being exploited?
There is no known exploitation of CVE-2024-4006 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-4006, GHSA-vjph-qj4m-f5g8, UBUNTU-CVE-2024-4006.