{"answers":{"affected":"6 open source packages ship an affected version, including com.graphql-java:graphql-java.","exploited":"There is no known exploitation of CVE-2024-40094 in the wild and no public exploit code.","fix":"Upgrade com.graphql-java:graphql-java to a fixed version for your release line: 19.11, 20.9 or 21.5.","what":"CVE-2024-40094 is a medium-severity denial of service vulnerability in n/a, published on 30 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-40094 and fix it if it is affected.\n\nWhat it is: CVE-2024-40094 is a medium-severity denial of service vulnerability in n/a, published on 30 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-40094 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.graphql-java:graphql-java (Maven): affected all versions; fixed in 19.11\n- com.graphql-java:graphql-java (Maven): affected all versions; fixed in 19.11\n- com.graphql-java:graphql-java (Maven): affected from 20.0; fixed in 20.9\n- com.graphql-java:graphql-java (Maven): affected from 20.0; fixed in 20.9\n- com.graphql-java:graphql-java (Maven): affected from 21.0; fixed in 21.5\n- com.graphql-java:graphql-java (Maven): affected from 21.0; fixed in 21.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-40094/ (Markdown: https://insights.sbomify.com/CVE-2024-40094/index.md)","id":"CVE-2024-40094","markdown":"https://insights.sbomify.com/CVE-2024-40094/index.md","name":"CVE-2024-40094","record":{"aliases":["CLEANSTART-2026-BT38651","CLEANSTART-2026-FI38634","GHSA-h9mq-f6q5-6c8m","MINI-cv2f-686c-73q7","MINI-vghx-vx7j-xj7x","ROOT-APP-MAVEN-CVE-2024-40094"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"GraphQL Java library","requires_auth":"none","summary":"Attackers can cause denial of service in applications using GraphQL Java by sending malicious introspection queries that bypass resource limits.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[],"description":"GraphQL Java (aka graphql-java) before 21.5 does not properly consider ExecutableNormalizedFields (ENFs) as part of preventing denial of service via introspection queries. 20.9 and 19.11 are also fixed versions.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":"2025-01-17","github_poc":1,"max_poc_stars":3,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-01-17T08:09:37Z","kind":"github_poc","ref":"https://github.com/kabiri-labs/CVE-2024-40094","stars":3,"title":"This script exploits the CVE-2024-40094 vulnerability in graphql-java"}],"tier":"poc_unverified"},"has_fix":true,"headline":"GraphQL Java does not properly consider ExecutableNormalizedFields (ENFs) as part of preventing denial of service","id":"CVE-2024-40094","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":6,"n_references":6,"next":{"headline":"Information disclosure in n/a","id":"CVE-2024-40096"},"packages":[{"ecosystem":"Maven","fixed":["19.11"],"introduced":["0"],"last_affected":[],"package":"com.graphql-java:graphql-java","purl":null,"source":"GHSA-h9mq-f6q5-6c8m"},{"ecosystem":"Maven","fixed":["19.11"],"introduced":["0"],"last_affected":[],"package":"com.graphql-java:graphql-java","purl":"pkg:maven/com.graphql-java/graphql-java","source":"GHSA-h9mq-f6q5-6c8m"},{"ecosystem":"Maven","fixed":["20.9"],"introduced":["20.0"],"last_affected":[],"package":"com.graphql-java:graphql-java","purl":null,"source":"GHSA-h9mq-f6q5-6c8m"},{"ecosystem":"Maven","fixed":["20.9"],"introduced":["20.0"],"last_affected":[],"package":"com.graphql-java:graphql-java","purl":"pkg:maven/com.graphql-java/graphql-java","source":"GHSA-h9mq-f6q5-6c8m"},{"ecosystem":"Maven","fixed":["21.5"],"introduced":["21.0"],"last_affected":[],"package":"com.graphql-java:graphql-java","purl":null,"source":"GHSA-h9mq-f6q5-6c8m"},{"ecosystem":"Maven","fixed":["21.5"],"introduced":["21.0"],"last_affected":[],"package":"com.graphql-java:graphql-java","purl":"pkg:maven/com.graphql-java/graphql-java","source":"GHSA-h9mq-f6q5-6c8m"}],"prev":{"headline":"Missing authorization in n/a","id":"CVE-2024-40091"},"products":["n/a"],"published":"2024-07-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-20","vendors":["n/a"]},"summary":"Attackers can cause denial of service in applications using GraphQL Java by sending malicious introspection queries that bypass resource limits.","url":"https://insights.sbomify.com/CVE-2024-40094/"}