# CVE-2024-40137: Dolibarr ERP CRM vulnerable to remote code execution (RCE)

> Attackers can execute arbitrary code remotely via the Computed field parameter in the Users Module Setup function of Dolibarr ERP CRM.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-vprp-94p9-5jp8, UBUNTU-CVE-2024-40137

## What is CVE-2024-40137?

CVE-2024-40137 is a medium-severity code injection vulnerability in n/a, published on 24 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Dolibarr ERP CRM before 19.0.2-php8.2 was discovered to contain a remote code execution (RCE) vulnerability via the Computed field parameter under the Users Module Setup function.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2024-40137?

2 open source packages ship an affected version, including dolibarr/dolibarr.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | All versions | 19.0.2 |
| `dolibarr/dolibarr` | Packagist | All versions | 19.0.2 |

## How do I fix CVE-2024-40137?

Upgrade dolibarr/dolibarr to 19.0.2 or later.

## Is CVE-2024-40137 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-40137 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-40137 and fix it if it is affected.

What it is: CVE-2024-40137 is a medium-severity code injection vulnerability in n/a, published on 24 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-40137 exists.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 19.0.2
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 19.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-40137/ (Markdown: https://insights.sbomify.com/CVE-2024-40137/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-40137
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-40137
- OSV: https://osv.dev/vulnerability/CVE-2024-40137

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-40137/
Summaries are generated and may contain mistakes; the official description above is the record.
