CVE-2024-4025 Inefficient Regular Expression Complexity in GitLab

Medium 6.5 Published Updated

An attacker can cause a denial of service in GitLab by submitting a crafted markdown page that triggers inefficient regular expression processing.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-4025?

CVE-2024-4025 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 20 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A Denial of Service (DoS) condition has been discovered in GitLab CE/EE affecting all versions from 7.10 prior before 16.11.5, version 17.0 before 17.0.3, and 17.1 before 17.1.1. It is possible for an attacker to cause a denial of service using a crafted markdown page.

Weakness: CWE-1333

Which versions are affected by CVE-2024-4025?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 7.10.016.11.5, 17.1.2

Products include Gitlab Gitlab.

How do I fix CVE-2024-4025?

Upgrade gitlab to a fixed version for your release line: 16.11.5 or 17.1.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-4025 being exploited?

There is no known exploitation of CVE-2024-4025 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-4025, GHSA-6w53-65xx-mgj9, UBUNTU-CVE-2024-4025.

Is CVE-2024-4025 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free