CVE-2024-40453 squirrelly Code Injection vulnerability
Attackers can execute arbitrary code via the options.varName parameter in the squirrelly JavaScript template engine library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-40453?
CVE-2024-40453 is a critical code injection vulnerability in n/a, published on 21 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
squirrellyjs squirrelly v9.0.0 and fixed in v.9.0.1 was discovered to contain a code injection vulnerability via the component options.varName.
Weakness: CWE-94
Which versions are affected by CVE-2024-40453?
2 open source packages ship an affected version, including squirrelly. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
squirrelly npm | From 9.0.0 | 9.1.0 |
squirrelly npm | From 9.0.0 | 9.1.0 |
Products include Squirrelly Squirrelly.
How do I fix CVE-2024-40453?
Upgrade squirrelly to 9.1.0 or later.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2024-40453 being exploited?
There is no known exploitation of CVE-2024-40453 in the wild and no public exploit code.
Public exploit code: 2 proofs of concept on GitHub.
Other vulnerabilities in n/a
Sources
Also known as GHSA-w5pw-gmcw-rfc8.