# CVE-2024-40597: Information disclosure in n/a

> The CheckUser extension fails to respect log deletion flags, allowing attackers to view suppressed log event information.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-mediawiki-2024-40597, GHSA-5cqg-h2ff-24hv

## What is CVE-2024-40597?

CVE-2024-40597 is a high-severity vulnerability in Mediawiki Mediawiki, published on 6 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the CheckUser extension for MediaWiki through 1.42.1. It can expose suppressed information for log events. (The log_deleted attribute is not respected.)

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-40597?

1 open source package ship an affected version, including mediawiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki` | Bitnami | All versions | 1.44.0 |

Products: Mediawiki Mediawiki.

## How do I fix CVE-2024-40597?

Upgrade mediawiki to 1.44.0 or later.

## Is CVE-2024-40597 being exploited?

There is no known exploitation of CVE-2024-40597 in the wild and no public exploit code.

## Other vulnerabilities in Mediawiki Mediawiki

- [CVE-2023-37303](https://insights.sbomify.com/CVE-2023-37303/): Denial of service in n/a (critical 9.8)
- [CVE-2022-29904](https://insights.sbomify.com/CVE-2022-29904/): SQL injection in n/a (critical 9.8)
- [CVE-2022-29906](https://insights.sbomify.com/CVE-2022-29906/): Missing authorization in n/a (critical 9.8)
- [CVE-2022-28205](https://insights.sbomify.com/CVE-2022-28205/): Business logic in n/a (critical 9.8)
- [CVE-2022-28206](https://insights.sbomify.com/CVE-2022-28206/): Missing authorization in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-40597 and fix it if it is affected.

What it is: CVE-2024-40597 is a high-severity vulnerability in Mediawiki Mediawiki, published on 6 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-40597 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki (Bitnami): affected all versions; fixed in 1.44.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-40597/ (Markdown: https://insights.sbomify.com/CVE-2024-40597/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-40597
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-40597
- OSV: https://osv.dev/vulnerability/CVE-2024-40597

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-40597/
Summaries are generated and may contain mistakes; the official description above is the record.
