# CVE-2024-40601: Cross-site request forgery in n/a

> Attackers can perform unauthorized actions via CSRF in MediaWikiChat API modules, requiring users to update the extension.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jul 2024
- **Updated:** 27 Oct 2024
- **Also known as:** BIT-mediawiki-2024-40601, GHSA-269f-h4cx-j3fr

## What is CVE-2024-40601?

CVE-2024-40601 is a medium-severity vulnerability in Mediawiki Mediawiki, published on 6 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in the MediaWikiChat extension for MediaWiki through 1.42.1. CSRF can occur in API modules.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2024-40601?

1 open source package ship an affected version, including mediawiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki` | Bitnami | All versions | 1.44.0 |

Products: Mediawiki Mediawiki.

## How do I fix CVE-2024-40601?

Upgrade mediawiki to 1.44.0 or later.

## Is CVE-2024-40601 being exploited?

There is no known exploitation of CVE-2024-40601 in the wild and no public exploit code.

## Other vulnerabilities in Mediawiki Mediawiki

- [CVE-2023-37303](https://insights.sbomify.com/CVE-2023-37303/): Denial of service in n/a (critical 9.8)
- [CVE-2022-29904](https://insights.sbomify.com/CVE-2022-29904/): SQL injection in n/a (critical 9.8)
- [CVE-2022-29906](https://insights.sbomify.com/CVE-2022-29906/): Missing authorization in n/a (critical 9.8)
- [CVE-2022-28205](https://insights.sbomify.com/CVE-2022-28205/): Business logic in n/a (critical 9.8)
- [CVE-2022-28206](https://insights.sbomify.com/CVE-2022-28206/): Missing authorization in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-40601 and fix it if it is affected.

What it is: CVE-2024-40601 is a medium-severity vulnerability in Mediawiki Mediawiki, published on 6 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-40601 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki (Bitnami): affected all versions; fixed in 1.44.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-40601/ (Markdown: https://insights.sbomify.com/CVE-2024-40601/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-40601
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-40601
- OSV: https://osv.dev/vulnerability/CVE-2024-40601

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-40601/
Summaries are generated and may contain mistakes; the official description above is the record.
