{"answers":{"affected":"4 open source packages ship an affected version, including org.geoserver.web:gs-web-app and org.geoserver:gs-rest. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-40625 in the wild and no public exploit code.","fix":"Upgrade org.geoserver.web:gs-web-app to 2.26.0 or later.","what":"CVE-2024-40625 is a medium-severity server-side request forgery vulnerability in geoserver, published on 10 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-40625 and fix it if it is affected.\n\nWhat it is: CVE-2024-40625 is a medium-severity server-side request forgery vulnerability in geoserver, published on 10 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-40625 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.geoserver.web:gs-web-app (Maven): affected all versions; fixed in 2.26.0\n- org.geoserver.web:gs-web-app (Maven): affected all versions; fixed in 2.26.0\n- org.geoserver:gs-rest (Maven): affected all versions; fixed in 2.26.0\n- org.geoserver:gs-rest (Maven): affected all versions; fixed in 2.26.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-40625/ (Markdown: https://insights.sbomify.com/CVE-2024-40625/index.md)","id":"CVE-2024-40625","markdown":"https://insights.sbomify.com/CVE-2024-40625/index.md","name":"CVE-2024-40625","record":{"aliases":["GHSA-r4hf-r8gj-jgw2"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"GeoServer","requires_auth":"high_privilege","summary":"Attackers can exploit the Coverage REST API to perform Server-Side Request Forgery by uploading files via arbitrary URLs, potentially accessing internal resources.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"geoserver","vendor":"osgeo"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"GeoServer is an open source server that allows users to share and edit geospatial data. The Coverage rest api /workspaces/{workspaceName}/coveragestores/{storeName}/{method}.{format} allows attackers to upload files with a specified url (with {method} equals 'url') with no restrict. This vulnerability is fixed in 2.26.0.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"GeoServer Coverage REST API Allows Server Side Request Forgery","id":"CVE-2024-40625","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"ssrf","year":"2024"},"n_packages":4,"n_references":3,"next":{"headline":"Stored Cross-site Scripting (XSS) vulnerability in Outline editor","id":"CVE-2024-40626"},"packages":[{"ecosystem":"Maven","fixed":["2.26.0"],"introduced":["0"],"last_affected":[],"package":"org.geoserver.web:gs-web-app","purl":null,"source":"GHSA-r4hf-r8gj-jgw2"},{"ecosystem":"Maven","fixed":["2.26.0"],"introduced":["0"],"last_affected":[],"package":"org.geoserver.web:gs-web-app","purl":"pkg:maven/org.geoserver.web/gs-web-app","source":"GHSA-r4hf-r8gj-jgw2"},{"ecosystem":"Maven","fixed":["2.26.0"],"introduced":["0"],"last_affected":[],"package":"org.geoserver:gs-rest","purl":null,"source":"GHSA-r4hf-r8gj-jgw2"},{"ecosystem":"Maven","fixed":["2.26.0"],"introduced":["0"],"last_affected":[],"package":"org.geoserver:gs-rest","purl":"pkg:maven/org.geoserver/gs-rest","source":"GHSA-r4hf-r8gj-jgw2"}],"prev":{"headline":"Deserialization of untrusted data in torrentpier/torrentpier","id":"CVE-2024-40624"},"products":["geoserver"],"published":"2025-06-10","related":[{"cvss_score":9.8,"headline":"Unfiltered SQL Injection Vulnerabilities in Geoserver","id":"CVE-2023-25157","kev_date_added":null,"published":"2023-02-21"},{"cvss_score":9.3,"headline":"GeoServer has improper ENTITY_RESOLUTION_ALLOWLIST URI validation in XML Processing (SSRF)","id":"CVE-2024-34711","kev_date_added":null,"published":"2025-06-10"},{"cvss_score":8.6,"headline":"Unsecured WMS dynamic styling sld=\u003curl\u003e parameter affords blind unauthenticated SSRF in GeoServer","id":"CVE-2023-41339","kev_date_added":null,"published":"2023-10-24"},{"cvss_score":8.6,"headline":"WPS Server Side Request Forgery in GeoServer","id":"CVE-2023-43795","kev_date_added":null,"published":"2023-10-24"},{"cvss_score":7.5,"headline":"GeoServer Vulnerable to Unauthenticated SSRF via TestWfsPost","id":"CVE-2024-29198","kev_date_added":null,"published":"2025-06-10"},{"cvss_score":7.5,"headline":"GeoServer has an Infinite Loop Vulnerability in Jiffle process","id":"CVE-2025-30145","kev_date_added":null,"published":"2025-06-10"},{"cvss_score":7.5,"headline":"GeoServer allows SSRF via the option for setting a proxy host","id":"CVE-2021-40822","kev_date_added":null,"published":"2022-05-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-10","vendors":["geoserver"]},"summary":"Attackers can exploit the Coverage REST API to perform Server-Side Request Forgery by uploading files via arbitrary URLs, potentially accessing internal resources.","url":"https://insights.sbomify.com/CVE-2024-40625/"}