# CVE-2024-40625: GeoServer Coverage REST API Allows Server Side Request Forgery

> Attackers can exploit the Coverage REST API to perform Server-Side Request Forgery by uploading files via arbitrary URLs, potentially accessing internal resources.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2025
- **Updated:** 10 Jun 2025
- **Also known as:** GHSA-r4hf-r8gj-jgw2

## What is CVE-2024-40625?

CVE-2024-40625 is a medium-severity server-side request forgery vulnerability in geoserver, published on 10 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

GeoServer is an open source server that allows users to share and edit geospatial data. The Coverage rest api /workspaces/{workspaceName}/coveragestores/{storeName}/{method}.{format} allows attackers to upload files with a specified url (with {method} equals 'url') with no restrict. This vulnerability is fixed in 2.26.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2024-40625?

4 open source packages ship an affected version, including org.geoserver.web:gs-web-app and org.geoserver:gs-rest. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.geoserver.web:gs-web-app` | Maven | All versions | 2.26.0 |
| `org.geoserver.web:gs-web-app` | Maven | All versions | 2.26.0 |
| `org.geoserver:gs-rest` | Maven | All versions | 2.26.0 |
| `org.geoserver:gs-rest` | Maven | All versions | 2.26.0 |

Products: Osgeo Geoserver.

## How do I fix CVE-2024-40625?

Upgrade org.geoserver.web:gs-web-app to 2.26.0 or later.

## Is CVE-2024-40625 being exploited?

There is no known exploitation of CVE-2024-40625 in the wild and no public exploit code.

## Other vulnerabilities in geoserver

- [CVE-2023-25157](https://insights.sbomify.com/CVE-2023-25157/): Unfiltered SQL Injection Vulnerabilities in Geoserver (critical 9.8)
- [CVE-2024-34711](https://insights.sbomify.com/CVE-2024-34711/): GeoServer has improper ENTITY_RESOLUTION_ALLOWLIST URI validation in XML Processing (SSRF) (critical 9.3)
- [CVE-2023-41339](https://insights.sbomify.com/CVE-2023-41339/): Unsecured WMS dynamic styling sld=<url> parameter affords blind unauthenticated SSRF in GeoServer (high 8.6)
- [CVE-2023-43795](https://insights.sbomify.com/CVE-2023-43795/): WPS Server Side Request Forgery in GeoServer (high 8.6)
- [CVE-2024-29198](https://insights.sbomify.com/CVE-2024-29198/): GeoServer Vulnerable to Unauthenticated SSRF via TestWfsPost (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-40625 and fix it if it is affected.

What it is: CVE-2024-40625 is a medium-severity server-side request forgery vulnerability in geoserver, published on 10 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-40625 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.geoserver.web:gs-web-app (Maven): affected all versions; fixed in 2.26.0
- org.geoserver.web:gs-web-app (Maven): affected all versions; fixed in 2.26.0
- org.geoserver:gs-rest (Maven): affected all versions; fixed in 2.26.0
- org.geoserver:gs-rest (Maven): affected all versions; fixed in 2.26.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-40625/ (Markdown: https://insights.sbomify.com/CVE-2024-40625/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-40625
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-40625
- OSV: https://osv.dev/vulnerability/CVE-2024-40625

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-40625/
Summaries are generated and may contain mistakes; the official description above is the record.
