{"answers":{"affected":"3 open source packages ship an affected version, including fastapi-opa.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-40627 exists.","fix":"Upgrade fastapi-opa to 2.0.1 or later.","what":"CVE-2024-40627 is a medium-severity vulnerability in busykoala fastapi-opa, published on 15 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-40627 and fix it if it is affected.\n\nWhat it is: CVE-2024-40627 is a medium-severity vulnerability in busykoala fastapi-opa, published on 15 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-40627 exists.\n\nAffected packages and fixed versions:\n- fastapi-opa (PyPI): affected all versions; fixed in 2.0.1\n- fastapi-opa (PyPI): affected all versions; fixed in 2.0.1\n- fastapi-opa (PyPI): affected all versions; fixed in 2.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-40627/ (Markdown: https://insights.sbomify.com/CVE-2024-40627/index.md)","id":"CVE-2024-40627","markdown":"https://insights.sbomify.com/CVE-2024-40627/index.md","name":"CVE-2024-40627","record":{"aliases":["GHSA-5f5c-8rvc-j8wf","PYSEC-2026-1361","UBUNTU-CVE-2024-40627"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"FastAPI OPA middleware","requires_auth":"none","summary":"Unauthenticated attackers can discover existing entities by sending HTTP OPTIONS requests, bypassing authentication checks in the FastAPI OPA middleware.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-204","name":"Observable Response Discrepancy"}],"description":"Fastapi OPA is an opensource fastapi middleware which includes auth flow. HTTP `OPTIONS` requests are always allowed by `OpaMiddleware`, even when they lack authentication, and are passed through directly to the application. `OpaMiddleware` allows all HTTP `OPTIONS` requests without evaluating it against any policy. If an application provides different responses to HTTP `OPTIONS` requests based on an entity existing (such as to indicate whether an entity is writable on a system level), an unauthenticated attacker could discover which entities exist within an application. This issue has been addressed in release version 2.0.1. All users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"OpaMiddleware does not filter HTTP OPTIONS requests","id":"CVE-2024-40627","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":3,"n_references":3,"next":{"headline":"Arbitrary File Read in Ansible Playbooks in Jumpserver","id":"CVE-2024-40628"},"packages":[{"ecosystem":"PyPI","fixed":["2.0.1"],"introduced":["0"],"last_affected":[],"package":"fastapi-opa","purl":null,"source":"GHSA-5f5c-8rvc-j8wf"},{"ecosystem":"PyPI","fixed":["2.0.1"],"introduced":["0"],"last_affected":[],"package":"fastapi-opa","purl":"pkg:pypi/fastapi-opa","source":"GHSA-5f5c-8rvc-j8wf"},{"ecosystem":"PyPI","fixed":["2.0.1"],"introduced":["0"],"last_affected":[],"package":"fastapi-opa","purl":"pkg:pypi/fastapi-opa","source":"PYSEC-2026-1361"}],"prev":{"headline":"Stored Cross-site Scripting (XSS) vulnerability in Outline editor","id":"CVE-2024-40626"},"products":["fastapi-opa"],"published":"2024-07-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["busykoala"]},"summary":"Unauthenticated attackers can discover existing entities by sending HTTP OPTIONS requests, bypassing authentication checks in the FastAPI OPA middleware.","url":"https://insights.sbomify.com/CVE-2024-40627/"}