# CVE-2024-40627: OpaMiddleware does not filter HTTP OPTIONS requests

> Unauthenticated attackers can discover existing entities by sending HTTP OPTIONS requests, bypassing authentication checks in the FastAPI OPA middleware.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-5f5c-8rvc-j8wf, PYSEC-2026-1361, UBUNTU-CVE-2024-40627

## What is CVE-2024-40627?

CVE-2024-40627 is a medium-severity vulnerability in busykoala fastapi-opa, published on 15 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fastapi OPA is an opensource fastapi middleware which includes auth flow. HTTP `OPTIONS` requests are always allowed by `OpaMiddleware`, even when they lack authentication, and are passed through directly to the application. `OpaMiddleware` allows all HTTP `OPTIONS` requests without evaluating it against any policy. If an application provides different responses to HTTP `OPTIONS` requests based on an entity existing (such as to indicate whether an entity is writable on a system level), an unauthenticated attacker could discover which entities exist within an application. This issue has been addressed in release version 2.0.1. All users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-204 (Observable Response Discrepancy)

## Which versions are affected by CVE-2024-40627?

3 open source packages ship an affected version, including fastapi-opa.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fastapi-opa` | PyPI | All versions | 2.0.1 |
| `fastapi-opa` | PyPI | All versions | 2.0.1 |
| `fastapi-opa` | PyPI | All versions | 2.0.1 |

## How do I fix CVE-2024-40627?

Upgrade fastapi-opa to 2.0.1 or later.

## Is CVE-2024-40627 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-40627 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-40627 and fix it if it is affected.

What it is: CVE-2024-40627 is a medium-severity vulnerability in busykoala fastapi-opa, published on 15 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-40627 exists.

Affected packages and fixed versions:
- fastapi-opa (PyPI): affected all versions; fixed in 2.0.1
- fastapi-opa (PyPI): affected all versions; fixed in 2.0.1
- fastapi-opa (PyPI): affected all versions; fixed in 2.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-40627/ (Markdown: https://insights.sbomify.com/CVE-2024-40627/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-40627
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-40627
- OSV: https://osv.dev/vulnerability/CVE-2024-40627

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-40627/
Summaries are generated and may contain mistakes; the official description above is the record.
