CVE-2024-40633 Customer data leak via adjustments API endpoint in Sylius
Attackers can enumerate adjustment IDs to retrieve order tokens and access sensitive guest customer data in Sylius.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-40633?
CVE-2024-40633 is a medium-severity vulnerability in Sylius, published on 17 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Sylius is an Open Source eCommerce Framework on Symfony. A security vulnerability was discovered in the `/api/v2/shop/adjustments/{id}` endpoint, which retrieves order adjustments based on incremental integer IDs. The vulnerability allows an attacker to enumerate valid adjustment IDs and retrieve order tokens. Using these tokens, an attacker can access guest customer order details - sensitive guest customer information. The issue is fixed in versions: 1.12.19, 1.13.4 and above. The `/api/v2/shop/adjustments/{id}` will always return `404` status. Users are advised to upgrade. Users unable to upgrade may alter their config to mitigate this issue. Please see the linked GHSA for details.
Weakness: CWE-200
Which versions are affected by CVE-2024-40633?
10 open source packages ship an affected version, including sylius/sylius.
| Package | Affected | Fixed in |
|---|---|---|
sylius/sylius Packagist | All versions | 1.9.12 |
sylius/sylius Packagist | All versions | 1.9.12 |
sylius/sylius Packagist | From 1.10.0-alpha.1 | 1.10.16 |
sylius/sylius Packagist | From 1.10.0-alpha.1 | 1.10.16 |
sylius/sylius Packagist | From 1.11.0-alpha.1 | 1.11.17 |
sylius/sylius Packagist | From 1.11.0-alpha.1 | 1.11.17 |
4 more packages
sylius/sylius Packagist | From 1.12.0-alpha.1 | 1.12.19 |
sylius/sylius Packagist | From 1.12.0-alpha.1 | 1.12.19 |
sylius/sylius Packagist | From 1.13.0-alpha.1 | 1.13.4 |
sylius/sylius Packagist | From 1.13.0-alpha.1 | 1.13.4 |
How do I fix CVE-2024-40633?
Upgrade sylius/sylius to a fixed version for your release line: 1.9.12, 1.10.16, 1.11.17 or 1.12.19.
Is CVE-2024-40633 being exploited?
There is no known exploitation of CVE-2024-40633 in the wild and no public exploit code.
Sources
Also known as GHSA-55rf-8q29-4g43.