# CVE-2024-40633: Customer data leak via adjustments API endpoint in Sylius

> Attackers can enumerate adjustment IDs to retrieve order tokens and access sensitive guest customer data in Sylius.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-55rf-8q29-4g43

## What is CVE-2024-40633?

CVE-2024-40633 is a medium-severity vulnerability in Sylius, published on 17 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Sylius is an Open Source eCommerce Framework on Symfony. A security vulnerability was discovered in the `/api/v2/shop/adjustments/{id}` endpoint, which retrieves order adjustments based on incremental integer IDs. The vulnerability allows an attacker to enumerate valid adjustment IDs and retrieve order tokens. Using these tokens, an attacker can access guest customer order details - sensitive guest customer information.  The issue is fixed in versions: 1.12.19, 1.13.4 and above. The `/api/v2/shop/adjustments/{id}` will always return `404` status. Users are advised to upgrade. Users unable to upgrade may alter their config to mitigate this issue. Please see the linked GHSA for details.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-40633?

10 open source packages ship an affected version, including sylius/sylius.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sylius/sylius` | Packagist | All versions | 1.9.12 |
| `sylius/sylius` | Packagist | All versions | 1.9.12 |
| `sylius/sylius` | Packagist | From 1.10.0-alpha.1 | 1.10.16 |
| `sylius/sylius` | Packagist | From 1.10.0-alpha.1 | 1.10.16 |
| `sylius/sylius` | Packagist | From 1.11.0-alpha.1 | 1.11.17 |
| `sylius/sylius` | Packagist | From 1.11.0-alpha.1 | 1.11.17 |
| `sylius/sylius` | Packagist | From 1.12.0-alpha.1 | 1.12.19 |
| `sylius/sylius` | Packagist | From 1.12.0-alpha.1 | 1.12.19 |
| `sylius/sylius` | Packagist | From 1.13.0-alpha.1 | 1.13.4 |
| `sylius/sylius` | Packagist | From 1.13.0-alpha.1 | 1.13.4 |

## How do I fix CVE-2024-40633?

Upgrade sylius/sylius to a fixed version for your release line: 1.9.12, 1.10.16, 1.11.17 or 1.12.19.

## Is CVE-2024-40633 being exploited?

There is no known exploitation of CVE-2024-40633 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-40633 and fix it if it is affected.

What it is: CVE-2024-40633 is a medium-severity vulnerability in Sylius, published on 17 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-40633 in the wild and no public exploit code.

Affected packages and fixed versions:
- sylius/sylius (Packagist): affected all versions; fixed in 1.9.12
- sylius/sylius (Packagist): affected all versions; fixed in 1.9.12
- sylius/sylius (Packagist): affected from 1.10.0-alpha.1; fixed in 1.10.16
- sylius/sylius (Packagist): affected from 1.10.0-alpha.1; fixed in 1.10.16
- sylius/sylius (Packagist): affected from 1.11.0-alpha.1; fixed in 1.11.17
- sylius/sylius (Packagist): affected from 1.11.0-alpha.1; fixed in 1.11.17
- sylius/sylius (Packagist): affected from 1.12.0-alpha.1; fixed in 1.12.19
- sylius/sylius (Packagist): affected from 1.12.0-alpha.1; fixed in 1.12.19
- sylius/sylius (Packagist): affected from 1.13.0-alpha.1; fixed in 1.13.4
- sylius/sylius (Packagist): affected from 1.13.0-alpha.1; fixed in 1.13.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-40633/ (Markdown: https://insights.sbomify.com/CVE-2024-40633/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-40633
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-40633
- OSV: https://osv.dev/vulnerability/CVE-2024-40633

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-40633/
Summaries are generated and may contain mistakes; the official description above is the record.
