{"answers":{"affected":"3 open source packages ship an affected version, including lollms.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-4078 exists.","fix":"Upgrade lollms to 9.5.0 or later.","what":"CVE-2024-4078 is a critical code injection vulnerability in parisneo/lollms, published on 16 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-4078 and fix it if it is affected.\n\nWhat it is: CVE-2024-4078 is a critical code injection vulnerability in parisneo/lollms, published on 16 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-4078 exists.\n\nAffected packages and fixed versions:\n- lollms (PyPI): affected all versions; fixed in 9.5.0\n- lollms (PyPI): affected all versions; fixed in 9.5.0\n- lollms (PyPI): affected all versions; fixed in 9.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-4078/ (Markdown: https://insights.sbomify.com/CVE-2024-4078/index.md)","id":"CVE-2024-4078","markdown":"https://insights.sbomify.com/CVE-2024-4078/index.md","name":"CVE-2024-4078","record":{"aliases":["GHSA-pwc9-q4hj-pg8g","PYSEC-2026-1593"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python LLM library","requires_auth":"none","summary":"Attackers can execute arbitrary code via path traversal in the unInstall_binding endpoint by loading malicious files.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"A vulnerability in the parisneo/lollms, specifically in the `/unInstall_binding` endpoint, allows for arbitrary code execution due to insufficient sanitization of user input. The issue arises from the lack of path sanitization when handling the `name` parameter in the `unInstall_binding` function, allowing an attacker to traverse directories and execute arbitrary code by loading a malicious `__init__.py` file. This vulnerability affects the latest version of the software. The exploitation of this vulnerability could lead to remote code execution on the system where parisneo/lollms is deployed.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Arbitrary Code Execution in parisneo/lollms","id":"CVE-2024-4078","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"Out of Bounds Read Due to Missing Bounds Check in LabVIEW","id":"CVE-2024-4079"},"packages":[{"ecosystem":"PyPI","fixed":["9.5.0"],"introduced":["0"],"last_affected":[],"package":"lollms","purl":null,"source":"GHSA-pwc9-q4hj-pg8g"},{"ecosystem":"PyPI","fixed":["9.5.0"],"introduced":["0"],"last_affected":[],"package":"lollms","purl":"pkg:pypi/lollms","source":"GHSA-pwc9-q4hj-pg8g"},{"ecosystem":"PyPI","fixed":["9.5.0"],"introduced":["0"],"last_affected":[],"package":"lollms","purl":"pkg:pypi/lollms","source":"PYSEC-2026-1593"}],"prev":{"headline":"WordPress UDesign theme \u003c= 4.7.3 - Reflected Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-4077"},"products":["parisneo/lollms"],"published":"2024-05-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-08","vendors":["parisneo"]},"summary":"Attackers can execute arbitrary code via path traversal in the unInstall_binding endpoint by loading malicious files.","url":"https://insights.sbomify.com/CVE-2024-4078/"}