CVE-2024-40886 One-click Client-Side Path Traversal Leading to CSRF in User Management admin page
Attackers can exploit client-side path traversal to perform CSRF attacks on the User Management admin page, potentially modifying user settings.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-40886?
CVE-2024-40886 is a medium-severity vulnerability in Mattermost Mattermost, published on 22 Aug 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Mattermost versions 9.9.x <= 9.9.1, 9.5.x <= 9.5.7, 9.10.x <= 9.10.0, 9.8.x <= 9.8.2 fail to sanitize user inputs in the frontend that are used for redirection which allows for a one-click client-side path traversal that is leading to CSRF in User Management page of the system console.
Weakness: CWE-352
Which versions are affected by CVE-2024-40886?
12 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | From 9.10.0 | 9.10.1 |
github.com/mattermost/mattermost/server/v8 Go | From 9.10.0 | 9.10.1 |
github.com/mattermost/mattermost/server/v8 Go | From 9.5.0 | 9.5.8 |
github.com/mattermost/mattermost/server/v8 Go | From 9.5.0 | 9.5.8 |
github.com/mattermost/mattermost/server/v8 Go | From 9.8.0 | 9.8.3 |
6 more packages
github.com/mattermost/mattermost/server/v8 Go | From 9.8.0 | 9.8.3 |
github.com/mattermost/mattermost/server/v8 Go | From 9.9.0 | 9.9.2 |
github.com/mattermost/mattermost/server/v8 Go | From 9.9.0 | 9.9.2 |
github.com/mattermost/mattermost-server Go | From 9.5.0+incompatible | 9.5.8+incompatible, 9.8.3+incompatible, 9.9.2+incompatible, 9.10.1+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost.
How do I fix CVE-2024-40886?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 9.10.1, 9.5.8, 9.8.3 or 9.9.2.
Is CVE-2024-40886 being exploited?
There is no known exploitation of CVE-2024-40886 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost
- CVE-2019-20851 Path traversal in n/a
- CVE-2024-39274 Malicious remote can add users to arbitrary teams and channels
- CVE-2024-39777 Malicious remote can invite itself to an arbitrary local channel
- CVE-2024-39830 Timing attack during remote cluster token comparison when shared channels are enabled
- CVE-2023-3615 Lack of server certificate validation in websockets connection
Sources
Also known as GHSA-hrf9-rm95-fpf3, GO-2024-3097.