# CVE-2024-40896: XML external entity in libxml2

> Attackers can exploit external entity processing in libxml2 to read sensitive files or execute code, bypassing custom SAX handler protections.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Dec 2024
- **Updated:** 28 Feb 2025
- **Also known as:** AZL-54657, BELL-CVE-2024-40896, BIT-java-2024-40896, BIT-java-min-2024-40896, BIT-jre-2024-40896, ECHO-b726-c9da-706c, GHSA-6c2p-rqx3-w4px, JLSEC-2026-468, MINI-23v7-r63c-fwv6, OESA-2024-1950, SUSE-SU-2025:20116-1, SUSE-SU-2025:20418-1, USN-7215-1, openSUSE-SU-2024:14241-1, openSUSE-SU-2024:14611-1, openSUSE-SU-2025:0024-1

## What is CVE-2024-40896?

CVE-2024-40896 is a critical vulnerability in Netapp H300s Firmware, published on 23 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In libxml2 2.11 before 2.11.9, 2.12 before 2.12.9, and 2.13 before 2.13.3, the SAX parser can produce events for external entities even if custom SAX handlers try to override entity content (by setting "checked"). This makes classic XXE attacks possible.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2024-40896?

3 open source packages ship an affected version, including java, java-min and jre. It affects 9 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `java` | Bitnami | All versions | 1.8.0, 8.0.461 |
| `java-min` | Bitnami | All versions | 1.8.0, 8.0.461 |
| `jre` | Bitnami | All versions | 1.8.0, 8.0.461 |
| `libxml2` | SUSE:Linux Micro 6.0 | All versions | 2.11.6-4.1 |
| `libxml2` | SUSE:Linux Micro 6.1 | All versions | 2.11.6-slfo.1.1_5.1 |
| `qt6-webengine` | SUSE:Package Hub 15 SP6 | All versions | 6.6.3-bp156.2.3.1 |
| `qt6-webengine-docs` | SUSE:Package Hub 15 SP6 | All versions | 6.6.3-bp156.2.3.1 |
| `qt6-webengine` | openSUSE:Leap 15.6 | All versions | 6.6.3-bp156.2.3.1 |
| `qt6-webengine-docs` | openSUSE:Leap 15.6 | All versions | 6.6.3-bp156.2.3.1 |
| `libxml2` | openSUSE:Tumbleweed | All versions | 2.12.9-1.1 |
| `qt6-webengine` | openSUSE:Tumbleweed | All versions | 6.8.1-2.1 |

Products: Netapp H300s Firmware, Netapp H410c Firmware, Netapp H410s Firmware, Netapp H500s Firmware, Netapp H700s Firmware, Netapp Hci Compute Node, Netapp Solidfire \& Hci Management Node, Netapp Solidfire \& Hci Storage Node, Xmlsoft Libxml2.

## How do I fix CVE-2024-40896?

Upgrade java to a fixed version for your release line: 1.8.0 or 8.0.461.

## Is CVE-2024-40896 being exploited?

There is no known exploitation of CVE-2024-40896 in the wild and no public exploit code.

## Other vulnerabilities in Netapp H300s Firmware

- [CVE-2022-2274](https://insights.sbomify.com/CVE-2022-2274/): RSA implementation bug in AVX512IFMA instructions (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-40896 and fix it if it is affected.

What it is: CVE-2024-40896 is a critical vulnerability in Netapp H300s Firmware, published on 23 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-40896 in the wild and no public exploit code.

Affected packages and fixed versions:
- java (Bitnami): affected all versions; fixed in 1.8.0, 8.0.461
- java-min (Bitnami): affected all versions; fixed in 1.8.0, 8.0.461
- jre (Bitnami): affected all versions; fixed in 1.8.0, 8.0.461

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-40896/ (Markdown: https://insights.sbomify.com/CVE-2024-40896/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-40896
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-40896
- OSV: https://osv.dev/vulnerability/CVE-2024-40896

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-40896/
Summaries are generated and may contain mistakes; the official description above is the record.
